Quick Controls hogs 'All MIDI-in' signals - bug/intentional?

Please note, Cubase 8.5 version.

I have my E-MU xboard control 25’s 8 top knobs assigned to quick controls, CC21-28 to Quick Controls 1-8. Channel1. Great, works.


But if I create a MIDI channel select ‘All MIDI-In’, these same rotary knobs are not being picked up by this MIDI channel. If I change the quick controls or erase them. The MIDI channel now works.

So interesting thing is, Quick Controls is on ‘All MIDI-in’. If I change the MIDI channel to be ‘E-MU Xboard 25’ directly, this problem also goes away, no conflict. This isn’t a solution for me though because I need multiple hardware inputs being fed in the same MIDI stream. I want to also decide on the fly whether to use Quick Controls or VST supported MIDI.

Edit

Also just discovered that if I disable Quick Controls on the MIDI Channel in inspector, problem goes away.

https://www.dropbox.com/s/du5zhu26ec5ek33/Cubase%20Pro%20Project%20-%20Cubase%20Preset%20Creation-186%202017-06-19%202_09_56%20PM.mp4?dl=0

Here’s a video showing what I’m talking about.

So if you can eliminate the problem by turning off Quick Controls on the midi channel you want to record CCs (not via Quick Controls), then there’s no problem, right?

It’s intentional. It reserves the individual CCs for the QCs or Generic Remote.

You need to change the CCs your keyboard controller is sending to otherwise unused CCs, and then set those up in Quick Controls in Device Setup.

Correct. Oddly enough, it’s only when ‘All MIDI-in’ is selected (or perhaps if what MIDI in option is selected in QC is same as on channel)

Maybe a smarter way to code this would be to only have this interference if Quick Controls is even being used and in a per controller/per QC slot basis, as seen in my video… I had nothing loaded in QCs, so no need for it to block MIDI signal.