Random MIDI Port / MIDI Device Anomaly

I’ve got three identical 8-port MIDI interfaces (MOTU MIDI Timepiece AV USB). Sometimes, when Cubase sends MIDI data to a MIDI port on an interface, it replicates the stream to every MIDI output port of the interface. This is indicated by the MIDI activity LEDs on the interface’s front panel. So, for example, if I’m routing a MIDI Track to a MIDI Device assigned to Interface #1, Port #1, I might see activity on all ports (1-8) of Interface #1. But not always. Sometimes, I’ll see activity only on Interface #1, Port #1, as would normally be expected. Why is this happening?

Choosing another destination for the MIDI Track sometimes makes the problem go away. Then, I can go back to the original destination MIDI Device and everything’s fine - at least, for a while. But it’s random. I can click through a dozen MIDI Devices and MIDI Ports with no effect, but then, suddenly, it’ll work and the problem will go away. When restarting Cubase and repeating the exact same steps, sometimes the problem will crop up on a MIDI Track. Other times, it won’t.

The issue is isolated to each interface so that, for example, if I get it fixed on Interface #1, the other two will continue to exhibit the problem until I get those fixed as well. Likewise, which interfaces are affected to begin with is also random.

Any ideas?

Firstly, I would check and possibly replace the first midi cord in the chain. (the one going to the “in” of the first interface) Get some contact spray and clean both the cable pins and the input holes.

I have three MOTU midi timepieces AV USB too and two 4x4 midisport plus an 8x8 and all seems to work as it should.
Maybe trash your preferences.

Not what I wanted to hear.

I’m beginning to think Cubase and I are not meant to be (and that Cubase is one of the buggiest pieces of software I’ve ever used - and this comes from an IT professional of 30 years). First, I spend six months learning Cubase 8.5’s eccentricities and workarounds. Then, I upgrade to Cubase 9 and all of my preferences disappear - had to rebuild everything from scratch. It’s just one more well-documented, years-old bug that remains unfixed. I can’t seem to go a day in the studio without finding another one.

So, the short answer is this: I just rebuilt all of my preferences. It’s pretty much a clean install of Cubase 9 on Windows 10. I’ll think about trashing my preferences but honestly don’t expect any change. It’s just another random ghost in the Cubase machine, yelling at me, “go back to Sonar!”

But thank you for verifying your MIDI interfaces are working. I’m encouraged to keep trying, at least, a little longer.

BTW, do you have trouble with Windows remapping your MOTU interfaces? I think Windows has trouble telling identical interfaces apart, gets confused, and reassigns them as ‘new’ devices. For example, after a clean installation of OS, interfaces, software, etc., you probably see eight instances of Port X on MTPAV in Cubase’s Device Setup > MIDI Port Setup. Plus, there’s eight instances of 2-Port X on MTPAV (your 2nd MOTU interface), and eight instances of 3-Port X on MTPAV (your 3rd MOTU interface). But when, I restart my PC, there’s a good chance that one or more of those interfaces will appear as 4-Port X on MTPAV, or 5-Port X on MTPAV, etc. The assigned numbers keep climbing and, unfortunately, each time this happens, the port preferences in Cubase (or any DAW) are lost. Consequently, devices don’t load properly. Old projects don’t load properly. It’s a mess.

This happens to me so frequently that I finally wrote a batch file to administratively purge all registered MOTU ports from the Windows OS so that, when I turn the interfaces back on in the desired order, their OS assignments are restored as before. [And, yes, any Cubase (or any DAW) port preferences are preserved, thank goodness.] It’s a nuisance and I have to run that batch script almost every day now.

Please don’t tell me you’ve never seen this before either. :unamused: But if so, have you found a better way to deal with it?

Any advice is appreciated.

…trouble with Windows remapping your MOTU interfaces?

Yep,it happened to me but only after disconnect and reconnect the usb devices to different ports.
There´s a procedure to remove “midi ghost devices” from the device manager (I assume that´s your batch file right?) and after that I have all my usb midi interfaces connected to the same ports to powered usb hubs and I always start them first before my PC.

This way I have no remap issues so far.My “Motus” are always the same 1-2 and 3.
Also I have several usb synths which are working fine (Moogs,Nord,Tempest,etc).

you probably see eight instances of Port X on MTPAV in Cubase’s Device Setup > MIDI Port Setup.

Respect to this remember that Cubase can use direct music,windows midi and emulated drivers.
Check this article:


Interesting. Yeah, I’m using Uwe Sieber’s Device Cleanup Cmd with a filter that wipes all the MOTU devices out of Windows:


Then, I power up the interfaces in the correct order and everything’s back to normal.

But, like yourself, I leave the USB cables plugged into the same ports and always power up the interfaces before the PC. So, go figure.

What I’m noticing lately is that Windows seems insistent on pushing interface #1 to #4. It happens almost every day - but not always. If I don’t reset, as described above, things might stay put (at 2, 3, and 4) until a power fluctuation or some other predictable event causes Windows to push things up to 5, 6, and 7, for example. [My PC is on a UPS but my studio racks and power receptacles are merely on line conditioners.] So, I wonder if the USB ports the interfaces are plugged into has anything to do with the order in which Windows addresses them. And I wonder if there’s any way to make this more consistent, so they’re always seen in the same order. I’ll have to experiment.

Thank you for your help!

Windows seems insistent on pushing interface #1 to #4

That seems to me that you have old drivers installed.

Have you removed old ghost drivers?
Try this :
at command promt (with adm right) type:
set devmgr_show_nonpresent_devices=1 (click return)
start devmgmt.msc (click return)
device manager will appear…click at menu show hidden devices.
with all your midi devices connected remove all grey ones.
Check if you’re still in trouble. If so,do the midi set up configuration and rename at Cubase.

Midi Port Set up configuration and rename:

At MIDI Port set up untick “Use Device Direct Music”
Then rename the similar port system name “shows as” to something different,e.g.:
If you have an instrument panel control like Yamaha AN1x and it uses port 1 on MTPAV but when you load at inspector the instrument you don´t get a sound and your panel is matched to another port 1 MTPAV…just select not connected and close the panel,then rename at MIDI port set up the matching port (port 1 MTPAV) to something else like “port 1 MTPAV AN1x”.
Then open the inspector and load your panel and when the midi connect menu appears select the renamed port.
That´s it. Next time you open that panel at inspector it will be connected at the correct port.
I suggest to rename all your similar ports and save your midi settings and if all goes fine save your preferences folder to another place.


Unfortunately, that didn’t do the trick, but in the process of fooling with it, I may have stumbled onto something else: It looks like Windows only rearranges the ports when I power up the computer too soon after powering on the MTP AVs. To clarify, my studio power is controlled by a couple of Furman line conditioners located in the control room’s racks, but the computer is located in a sound-isolated equipment closet. It usually takes me ten seconds to walk from the control room to the CPU and flip the switch. But when I take my time - say, 30 seconds or more - no trouble!

This is why I haven’t replied to your post sooner. I wanted to see if the theory held up. So far, so good.

But it begs the question: Does the MOTU MTP AV have a bootup time? They look like they power up pretty much instantly. Go figure.

Thank you for your help! I did manage to find some other “ghosts” in my drivers through your recommended cleanup method, so it certainly didn’t hurt to try.

It seems that those MOTU MTP AV have an internal battery (CR 2032) that is required to inform the pc and maintain their midi connection.
When the battery dies WIndows see it as a new midi device every time it boots and re-install it in a different port.
So just open the MOTU and replace the battery.
I did it with two of mines.

No kidding?! I’ll check that out, ASAP. Putting all the MTPs on the same circuit (so they power up together / in the same order) also seems to have helped but I still see the issue once every week or so. It’s a constant nuisance.

Can’t wait to try this out. I’ll report back.


So far, so good.

I swapped the CR2032 batteries in all three of my MOTU MIDI Timepiece AV USBs a week ago and haven’t had any trouble since. I’ve even powered things up out of order - traditionally, an absolute no-no - and seen no issues whatsoever. I hate to jinx it, but this aggravating li’l thorn in my side appears to be GONE! Woohoo!!!

THANK YOU!!! :smiley: