Random quantise

I don’t seem to be able to get random quantise. I have gone through the relevant paras in the manual but still can’t figure it out. I seem to get some notes move a whole 1/4 bar or so, whereas I want all the notes just to move, say, 15 ticks in different directions. The requirement is the usual in that I have 2 (duplicated) MIDI tracks with violins and I want them to be slightly different in their timing (so as to differentiate them). Can someone point the way please?

You’re too early.
It’s not April Fool’s day for months yet. :laughing:

You have more options, how to make your tracks quantized and live together.

You can use interactive quantize (iQ), which means, you set some %. Quantize will be set by this % (your earlier notes will be earlier too, your late notes will be late, but not so much), not to 100%. Of course, you can set different iQ for different tracks, so it will sound little bit different.

You can use Non-Q. It means, if some of your notes will be close to the grid (of course, you can set, if it will be very close, or not), Cubase will not quantize them at all.

You can use Random. It will quantize notes to 100% (or to different %, if you use iQ), and after this, all notes will be moved randomly by few ticks (you will set, how many ticks).

Very customisible, and useful.

You can use interactive quantize (iQ),

Just in case he needs to search. Should that be iterative Q? I’ve done that too. Unless I’ve missed a new I.Q. feature.

I’m sorry, you are right, of course! iPad’s auto-correction made its job. :-/

Thanks for the reply, Martin. Yes, it’s Random that I need, but I don’t quite get how to set it. As per the manual I go to the quantise panel, set the random to, say 15 ticks, then click quantise. However, some notes move much more than 15 ticks - to the extent that I think it is fully quantising some notes. Am I doing it the correct way?

Just set lower value of Random ticks. :wink:

That would make sense, except that 15 ticks is very small and some notes are moving a lot more than that. No matter, thanks anyway, there’s probably something I am doing wrong, so I’ll take another look at it.

What are you trying to randomise?
I usually find that any live playing I do where I don’t want overQing I’ll set at 64 note trips.
Or are you trying to humanise an existing (over quantised for your needs) drum track or something like that?

You could try randomising different length sections or just sections that sound like they need it but generally I find that less is more when trying to be “naturelle”. I also find that using the more esoteric and detailed parts of Cubase sometimes much slower than physical input just from finding out, and then remembering how, they work.

In my opinion, if you need quantize, best way is to use interative Quantization (no-iPad, so the name should be right). :wink:

If you are getting very unexpected results, I am wondering if you had already quantized those notes previously, before trying to randomize. Try applying Edit menu>Advanced Quantize>“Freeze MIDI Quantize” before you then try to randomize.

Thanks Vic, that’s interesting. Yes, I have already quantized the track. I will take a look at what you say.

As noted in my first post, what I have is a MIDI track that has been recorded live from a keyboard. A VST is applied to that track (in this case violin). Then, because many notes are well out of timing I have quantized it, and at that point I want to get all notes exactly on the measures so that I can work from there. So I have one fully quantized violin track.

However, I need two violins, so I duplicated the track. But I would not want the playing to be fully quantised, and I don’t want both tracks to be exactly the same as each other, so I want to apply a little random quantize to each track. Then each track is just a little out (so it is humanised) and the tracks are not exactly the same (as if I recorded both separately). But achieving that is what am having a problem with.

In that case, do try freezing your quantize first. Unlikely though it might seem, when you apply further parameters to the quantize, it does so from the original positions, not from the positions after your previous quantizing (so, by freezing the first quantize, you fix their positions, so that randomization will take place from there now :wink: ).

Then, because many notes are well out of timing I have quantized it,

Gotcha. Just try, if the track is not too cluttered by too far out notes, quantising the sections that need it the most using iterative quantise then copy it and apply IQ to the copy. You could do that in stections too. Takes a bit longer but maybe a better (or worse) approach.
Very small amounts of FX like reverb and distortion can also be applied to one track only or the same FX to each but increase the main FX parameters to one track only by a very small amount. This may simulate some of the effect you’re trying to acheive.

I believe that the Midi Logical Editor will randomize note positions if you want to do that.

Another thing you can look for is a humanize function to use after quantize, which will also shift some note positions and velocity values around by very small random amounts I think.

Also, if you’re layering midi parts with the exact same timing, you can use track delay to get additional offset.

The best way to do that (imo) is to just not duplicate parts like strings, but play them all separately and use 50% quantize steps on them all, which will nudge towards the quantize values but won’t have all the notes on multiple tracks hitting at the exact same time which sounds unnatural. I mean, if you want four string parts to sound like four people playing, play it four times to get the natural timing variations. and don’t hard quantize.

Yes, Logical Editor can randomize your notes very easy.

Check the very easy “script” in the picture, which makes this.
Screen Shot 2012-10-05 at 7.39.27.png

Great help guys, many thanks!

Vic - your comment about Cubase quantizing from the original position, and therefore you need to freeze it, is a revelation. I did not know about that issue, and I am sure that was causing the problem that I could not figure out!

Conman - good point about treating the tracks differently, and I do in fact use different instrument articulations on the tracks.

Audiocave - great call on the Logical Editor. I actually think I may have used it before, but had forgotten about it. And of course, you are absolutely correct about the real solution being to play the tracks separately. I plead guilty to being lazy and trying to use technology to get round an essentially musical problem!

Martin - thanks for the screen shot, very helpful in getting it sorted quickly.

Thanks again guys, great help and the whole thing makes much more sense now!

I use the Modifiers tab for the MIDI track in question. There’s an option to randomize position and you can set the range in ticks. Usually +/- 6 does the trick for me and loosens things up enough to sound human. The nice thing with this is that it’s non destructive. You can leave everything on the grid for editing purposes, and Cubase will humanize it in real time. You can also randomize velocities using the same panel.

And of course, you are absolutely correct about the real solution being to play the tracks separately.

Play two takes on different tracks, make sure one (A) is useable for the job and the other (B) is reasonable enough and mute it or park it somewhwere.
Copy A and apply effects as suggested (track C) (this line is the way you currently work)
and use track B to add anything relevant for the timing.

If doing string parts that you want to score then your midi needs to be quantised to the point it sounds unnatural to look anything like good on the page. And if that is the case then Vic France seems to be the chief resident Score expert.

Thanks for the additional comments. I think I have it working well now, but I will also take a look at the Modifiers tab. And yes, regarding the scoring issue, Vic very kindly helped me out on that in another thread a while ago.