(REAL SOLUTION) TO FIX- DCOM Synsopos.exe Error on Windows

STEINBERG Please improve and share this information! there is thousands of your users having this problem as I can see now, just make a re-search on this forum typing DCOM and you will find a lot of people experimenting this…

Today was my most frustrating day ever! I spend it all day trying different things to get this solved, since Im working daily on Cubase and to wait tech support is impossible. So I found the solution and I hope this can help to lot of affected people using Windows.

This problem seems to come directly from Windows and its related to: DcomLaunch / DCOM Server.

Real Solution:

step 1 unplug your USB dongle and make a clean uninstall of eLicenser.:

https://helpcenter.steinberg.de/hc/en-us/articles/206116944-How-to-uninstall-the-eLicenser-Control-Center-License-Control-Center


step 2 open CMD with admin rights:

1 Type: sfc /scannow

wait until the process is finished.

step 3 edit registry to fix DCOM by following this steps:

https://forums.tomshardware.com/faq/windows-10-error-id-10016.2752271/

  1. Type or paste ‘regedit’ into the Search Windows box.
  2. Navigate to ‘HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole’.
  3. Delete these four keys if they appear, DefaultAccessPermission, DefaultLaunchPermission, MachineAccessRestriction, MachineLaunchRestriction.
  4. Reboot your computer.

step 4 re-install eLicenser and plug your dongle again.


The step 3 will make the work, however, I recommend to do the 1 and 2 for clean any kind of problem.

I hope Steinberg can improve this information and share it to help a lot of people! :exclamation:

Hi,

Thank you!

You welcome! I hope it helps

Thank you that worked!

But now I’m not quite shure what to do: When I try to start Dorico 3.5 the following happens:

First: “No license was found. Click enter activation code to launch E-licenser…”.

Then: (see attached pictures)

  • since I am migrating from my old pc to a new one, do I need to reactivate my license or is the problem that the usb dongle isn’t being recognized?
    4.JPG
    3.JPG

Are you using a dongle USB? if your license is in the USB, try to plug in another USB port, since license must be housed there.

When you plug the USB, what it appears in “My Licenses” ? I see your selection in the image is placed in your Disk