Real-time rendering doesn't

Hi. I’ve been using WaveLab for a few months now, and I have an external device chain that I use in my master section. This means when I render, it does it in real-time, so my external devices can get a crack at the audio.

Today, it doesn’t do this anymore. Whether I select real-time rendering or not, it renders in faster-than-realtime mode, and it renders only silence. It renders it really fast, though!

I thought real-time mode was supposed to be forced on whenever you have an External FX in the signal path. This doesn’t seem to be working for me at all.

I’ve checked that my master section isn’t bypassed, and that my audio montage is not using the bypass master section option.

What am I missing?

Hi!

Maybe sample rate is/has change or clocking
perhaps tell more about your setup/audio device etc
it can give others an idea here…

regards S-EH

What has changed on your side?

Thanks for the replies. I’m using a Focusrite Red8Pre Thunderbolt audio interface, at 96k. Hardware-wise, nothing has changed since the other project.

The other project was set up with a single plugin (FabFilter Pro-Q3) on each clip in the montage, no effects on the track or montage output, and the analog outboard chain in the master section, followed by FabFilter Pro-L2 and dithering. The new project has three plugins on each clip: FabFilter Pro-Q3, Gullfoss, and a second analog outboard chain, set up in “split” mode (as send/return).

Today I’ll go through and disable plugins one by one and compare to the old project (and, I should have tried loading up the old project to see if that one still renders real-time; I’ll do that today).

Mostly I was hoping that by posting here someone would say “oh, that’s a common problem, you forgot to check this checkbox.”

The problem even if you do this?..
image

Yes; both of those do the same thing. It acts as though it’s going to do a realtime render; it just … doesn’t.

I loaded the old project, and it doesn’t render realtime anymore either; same thing happens.

I should have mentioned that the external effects are indeed applied upon playback; playback sounds perfect.

When I hit render (or Start Rendering (Real Time) and hit the start button), it renders my whole project, and the progress meter goes at about 4x realtime, but the resulting audio files are empty (silence, duration 0:00).

The only software changes I’ve made since last time are installing MidiQuest and updating Roland Cloud, which gave me a new version of the Zenology plugin that crashes Cubase, so I disabled that. I can’t think of anything else that has changed, except the knobs on my analog compressors.

Other things I thought of that had changed: I installed NoMachine since then. (I’ve disabled it, but it didn’t help.) I had changed my ASIO-Guard settings. I changed them back (and rebooted), no change.

I’m running Mac OS Catalina 10.15.7, and have (just now) updated WaveLab to 10.0.70.180 (was on 10.0.50).

Realtime rendering works in a fresh project. Now I’ll start adding things until it stops.

Found the culprit: SonarWorks SoundID Reference VST Plug-in, in the “Playback Processing” part.

Thanks for the update.