Realtime midi input not honoring quantization settings

Almost all day I’ve been entering short hymns via real-time midi input. It’s worked quite well. However, when I went to input the last one of the day, I’m getting 1/16 notes and inaccurate rhythms (something I didn’t have a problem with earlier in the day). In program settings the midi input quantization is set for 1/8 notes. So why am I getting 1/16th notes? If quantization is set to 1/8 notes there is no reason I should ever get 1/16th or smaller values when doing realtime midi input. I even exited Dorico (as it had been running all day) and tried it, still getting 1/16 notes even when quantization is set to 1/8th notes. I’ve tried different metronome speeds and still get 1/16 notes when I shouldn’t.

I’ll need to check with Paul to be completely certain, but I believe that Dorico will still notate shorter values than the minimum quantized value under duress, if it feels it has no other option. If the issue is that you are ending up with rests when you don’t want them, try using Write > Edit Durations > Extend to Next Note (also accessible via the jump bar) to remove the rests by extending the selected notes to the start position of the next note.

It’s not rests that’s the problem, its multiple 16th notes showing up where I’m only playing 8th notes. Sometimes there will be a 16th tied to a 16th with the 2nd 16th having a harmony note even though I’m only playing one note at a time. It’s also odd that other similar songs I’d entered earlier today didn’t have this issue. The only difference I can think of is that the melody of this song had a lot of repeated 8th notes rather than different pitches. Maybe a keyboard issue?

Would be nice if you could share a screenshot of the problematic area of the score (of course a project file including only the problematic part, too).
I have a hypothesis on your issue, but I would like to check if it’s what I’m thinking about, or not.

Best wishes,
Thurisaz :slight_smile:

If you’re finding that Dorico is producing unexpected overlaps during recording, you can of course use the Shorten to Next Note tool (also found via the jump bar, or in Write > Edit Durations) to remove overlaps.

But it would be interesting to know why you’re getting unexpected overlaps. When you record in real-time, Dorico actually saves a MIDI file to a temporary location and then imports that MIDI file at the desired position. So if you reproduce this again, we could take a look at the MIDI files and see exactly what data Dorico has to work with.

I can’t replicate the overlaps, but attached is the project and partial source. I guess technically there isn’t anything less than an 1/8 in length, but I’m use to my DAW (reaper) that can quantize on input. It quantizes to the grid - that is nothing starts on or lasts shorter than an 8th note. So in this example the first note of verse 4 should start on either the “and” of 4 or on beat one. That’s my understanding of quantization. Not just note length, but where the notes are positioned in a measure. What’s odd is that I played in verses 1 & 2 with nothing shorter than 8ths showing up, both length and location. But when it came to 3 (now cleaned up), 4 & 5 I never could get a satisfactory input from playing the notes in. (I’m an advanced level pianist). I did verse 4 at 60 BPM and verse 5 at 120 BPM. Do I need to play further behind the beat instead of my tendency to play a bit ahead of the beat or what?
RS2016-1033-eat_this_bread.dorico (435.7 KB)

It might be worth seeing whether adjusting the MIDI delay compensation value provides any improvement:

I just tried playing in the 4, 5 and then 3rd verses. All I did was open my template (new project), press record. Guess what? Except for one note everything was correct and no 16th notes. I don’t get it why it works now and didn’t earlier. I tried it again in the original document and except for one time the rhythms were all over the place and I did have 16th notes all by themselves (rests on either side).
I experimented some with latency. +125 did help some in the original document, but since 0ms in a new template/project worked I’m not sure if latency is something to mess with.

I’m revisiting this as I’ve run across this again. I think the problem is that I’m adding a lot of 4/4 measures with a 1 beat pickup (using the popover) between sections, then doing real time input. I start getting input starting a 1/16 off or odd rhythms about 30 measures or so in. If I open a new project using the same template and input the problem sections, it works just fine. I’m attaching the project. Delete the notes in verses 6 to 9 and try real time input and see if you get weird results. (Quantization set to 8th notes). If not, I’ll consider the problem somewhere on my end.
RS2016-594.dorico (477.1 KB)

As an experiment, could you try going to Play > Playback Options, and on the Repeats page, switch off Play repeats, then Apply and Close, then try recording again. Do you get a better result?

I’m curious why your solution works, but it does, perfectly. (BTW, I found the option in Library->Playback options, not Play->Playback Options). Thanks.

Oops, quite right – the Playback Options dialog of course migrated to the Library menu in Dorico 4, but old habits die hard.

I just upgraded to Dorico 5.1 from Dorico 4, but I am encountering the same problem. When I set the quantization to eighth notes, I get 64th notes in my score. Due to this, live recording is unusable, which was my most-used feature in Dorico 4. Is this a known issue? Thank you.

No, this isn’t a known issue. Are you playing very fast notes during input? If you’re playing very fast notes (64th notes of course being four times faster than eighth notes), Dorico will under duress use shorter note values, because otherwise it would be forced to notate chords.

Since I started this thread I’ll add that I’m still having some issues. When engraving hymns that start with a refrain then have 3 or 4 verses, each different enough of a melody to require separate notation I have issues. Each verse starts with a pickup bar (of various values from 16th to half), the refrain ending with an incomplete bar. The verses DC to the beginning. I change the meter in those measures before starting real-time input, usually as I get to each verse. Once I start inputting the 2nd through 4th verses I usually end up with notation that includes 16th or 32nd notes even though I have the quantization set to 8th notes. I don’t do enough hymns like this to remember if it happens every time or not, but it does happen enough for me to consider it a known issue. I find if I remember to enter all the notes first, then go through and put in the pickup or incomplete bar measures I don’t have the issue. But starting real-time input after I’ve made time signature changes I do have issues.

I am playing quarter notes, and the quantization is off. I have using notation software for more than 15 years, including Dorico, and it never happened before.

Ok, I think I figured out a solution. In general preferences (‘cmd+,’ in mac) > Play > Quantization, I marked “Fill Gaps” and the problem was solved. Thanks.