Recent MIDI weirdness!

I had some issues with Cubase not recognising MIDI and Hanging on start up, sometimes not closing down.
Steinberg advised that I trash a file called Cubase 12_64 that resides in App Data Roaming.
This trashes all your prefs, it looses your templates and presets too. I have refound the templates and rebuilt the presets and prefs.

Although this [did not] cure my original issues, this also introduced a new weird one. [Edit Note these issues are back!]

For some reason if I try to resave an existing project with the same name, it never appears in the Recent list. If I create a new project and save this, it does appear in the recent list?

Anyone have a solution?

Is this a known issue after trashing settings?



What exactly do you do, please? Where does the project come from?

Thank you.
I have a long list of templates, called Only Library name x, y, etc. each also has a project of the same name in a folder of same name. If I load the project, then save it, it does not appear in the recent list. If I load a template and then save it by overwriting the appropriate named project this also does not show in the Recent list of the new project dialogue. They do show in the list at the bottom of the file menu or by right clicking on Cubase 12 icon on Windows toolbar.

If I create a new project with a novel name these save properly. This fault has begun after trashing the file above


It definitely doesn’t have anything to do with the preferences cleaning.

Do you make some changes in the project?

Hi Martin,

Yes, I have learnt the hard way. Steinberg told me to trash the Cubase folder in users. I did this, I reinstalled Cubase, rebuilt prefs, shortcuts and all the other stuff. It has made no difference. It happens in all projects. I notice that after I switch off my PC the first load hangs on Mackie which happens to be the last thing to load. It was doing this before I had this Mackie too freezing. Then, Cubase loads but does not respond to MIDI, though it will play if, for example, you strike a note on a MIDI virtual keyboard, it does not play when you strike the real one. After two or three attempts at reloading Cubase it reloads correctly and I can work.

Yesterday, for the first time, I noticed more weirdness inside East West Opus. I loaded a string patch and it worked, then after a recording, I went back to it and it was silent. Within the app I reloaded the same patch over itself, it then worked again.

I really don’t understand this

thanks for trying


btw its all projects


Make sure, all your plug-ins are up to date, please.

As far as I know all ,my plugins are up to date- there are hundreds. Anything weird gets binned

@ZeroZero In my experience, midi/software hang happens due to using old soundcard, or old USB 2.0 midi controllers with x86 driver plugged into a latest computer with USB3. As much everything is supposed to be forward & backward compatible, the whole system doesn’t integrate well sometimes . Always some driver c#$%p.
Using any virtual midi cables? Also try disabling inbuild soundcard driver from the Control Panel. I remember 5 years ago when that took care of random crashes.

On the issue of projects not showing in the recent list - You might just have to reinstall Cubase again. But do check if the Recent List thing works before trashing anything from App Data. Hopefully it will fix that. Much less time consuming than finding answers is what I feel.

About your East West Opus going silent -When Opus goes silent, do other vsts instruments go silent too? We might be able to find out if its the plugin or Cubase or something else.

I have a Focusrite 18i20 with updated drivers. All other sound drivers disabled. All other drivers up to date. No virtual cables. All USB drivers are up to date. All other standalones - Kotakt, TruePianos etc work, its just Cubase. I am now detecting Cubase does not shut down correctly from task manager after a faulty start, this is new behaviour. In Task manager there are 3 Entries for Cubase, when frozen and then shut down in Task Manager one remains and prevents MIDI in other standalones until restart.

I have not had a repeat of the Opus behaviour. It’s now taking at least 4 times to reopen Cubase before MIDI starts working. USB selective suspend is disabled and all power saving options. I have re-installed Cubase


Do you have any older Cubase version(s) preferences folder? Could you try to (backup them and) delete then too, please?

No older versions on this system


Do you mean now, or it has never been installed on the system?

TBH I can’t remember. Meanwhile, here is a link to the crash dumps if this is any good. Thank you Martin Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.


The problem is in the MIDI Out port. What MIDI Device do you use? Could you reinstall its driver? Could you install the driver as an administrator? Have you installed Cubase as administrator?

I think your onto the right track, Martin. I currently have two MIDI devices - my keyboard a lovely RD700NX. Had this ten years no problem although it’s not a MIDI controller as such, it’s a stage piano. Then I have a 4 fader custom device USB &TRS MIDI Controller 8 Faders programmable CC#/Channel/Range DAW/ | eBay. I use this for Composing - CCs. I have set this up as a Mackie Device (warning I am hopeless in Studio Set up issues).

If I unplug this device Cubase loads correctly and my piano plays MIDI.

The Mackie device has a MIDI input and output setup as “Arduino Leonardo” but nothing else has been set. I bought this on ebay and am generally pleased with it.
Is there a setting I should tweak in the Studio Setup Martin? I have no clue. The Ebayer is not helpful and says “he does not own Cubase”. No driver. All I need is CC control from the faders.

Is there anything I can do Martin?

Here are a couple of pics.



I would expect the issue is in the “USB &TRS MIDI Controller…” MIDI Driver. Did you install any? Or is it plug & play device?

Why did you choose Mackie for this device? Does it send PitchBend at channels 1-8? Do you want to control MixConsole’s faders with the device?

I did not install any driver at all - ther is none as far as I am aware. After 4-5 attempts at loading Cubase, the faders do work for CCs. This is all I need.
I have no idea what a USB & TRS driver is. Would it show up anywhere? Its not in the ddvicec manager as far as I can see.
It’s a plug and play device I think. I only want to control CCs and allocate them by right clicking on a virtual instrument parameter. I don’t need pitch bend much though this is a CC. All I really need are the usual Mod CC1, CC11 Expression, CC7, CC2. I don’t need to control the mixer. CCs only.

I got into a complete mess trying to use MIDI Remote integration, it just did not work and I was advised in a thread here, it was not to be used.
The guy I bought this from mentioned Mackie but he followed up by saying to the effect he does not really know Cubase at all.
I always get into messes with controllers - waste weeks. Beyond the CC list and Velocity I simply do not understand anything about them and know nothing about which software controller map to use and how to set it up. Poking around in the dark here.

Happy to try other options.

Thank you Martin.



Delete the Mackie Control Device in Cubase, please.