Record in Editor - preferences option

Can we have an option in the preferences to have “Record in Editor” permanently on?

I’m not sure if it’s a bug with 9.5 but I seem to be turning this option on constantly. Even after I turn it on for one part. Open another and it’s often off.

Personally I don’t ever need the button to be off but if there was an option in preferences that would cater for all users…

Yes! I’ve been complaining about this for a year! Why is this even a function? Who requested to have the option to NOT record in an editor? It doesn’t make any sense.

I have the exact same issue you have, and I’ve figured out (for me at least) that when you have “record in editor” enabled and then disable “Editor follows even selection” (or whatever it’s called), save your project, quit Cubase, then load the project, “record in editor” is disabled again. It’s incredibly annoying and pointless.

Glad it’s not just me! :slight_smile:

I am bumping and stressing this thread because, even though this isn’t a big issue to many, it’s a big issue to some who have used Cubase for years. You have many professional and more in-depth users who have very specific problems which seem to be ignored. It’s nice to see you roll out a quick update when lots of people complain, but what about us who know and use Cubase far beyond the basic features? I can list a number of functions that have literally been broken in the past few years which have never been addressed, but I know I need to stick to one issue per thread.

The “record in editor” button/feature in the key editor was NOT a good implementation. I’ve used Cubase since version 4 and I never had any issue with how the key editor worked concerning recording. It was PERFECT in the past; if I wanted to record in the editor I had the editor in focus. If I didn’t want to record in the editor, I did not have the editor in focus. Simple and makes sense. So like I asked previously: what is the purpose of the “record in editor” option/button? Even when watching your YouTube tutorials, the person presenting the video opens the key editor and “record in editor” is defaulted to being off. Why?

Like I said, it randomly turns off when I reopen a project. I’m not sure if it has to do with “editor follows event selection” turned off, but PLEASE Steinberg, fix this or (even better) remove this function.

I just tried a few tests on this “record in editor” function, and it seems that it doesn’t matter if you have “editor follows event selection” turned on or off at all. If you have the key editor open in a separate window (not just the lower zone), save the project, then quit Cubase, the “record in editor” button is turned OFF. The only way it stays ON is by saving your project with it ON in the lower zone and the key editor window closed.

So I’m guessing this is more of a BUG rather than a feature request.

Let’s hope steinberg read this and sort something out for C 10.5.41 :joy:


My guess is it will never be fixed. It seems things are only addressed if lots are complaints are made. So far it’s only you and me. :frowning:

Maybe report this as a bug.

Thanks, will do now. :slight_smile:

I’ve tried. Apparently it’s not a bug, it’s a feature :slight_smile: