"Record in Editor" Record Enables previously selected tracks (successfully reproduced)

After 8 years of not having any clue what is causing “random” Record Enable on tracks, through several screen casts of myself working I’ve now been able to successfully reproduce the bug. This is the most annoying workflow killer for me on an every day basis, so I really urge Steinberg to fix this as soon as possible. I’m constantly shifting between “Record in editor” enabled/disabled to record Midi-CC data under already recorded notes, and it’s driving me crazy.

Unluckily, a new version was released today, I hope a quick fix for this can be released soon. I will also contact support and point to this thread.

Here is a video showcasing the bug:

macOS Monterey 12.6.2
Nuendo 12.0.40 (no updates to this in versions after, I can’t update right now for several reasons).

Steps to reproduce:

  1. Set up Preferences:
  • Track Selection follows Event Selection = OFF

  • Enable Record on Selected MIDI Track = ON

  1. Create x10 Instrument Tracks (fewer works, but for the sake of the argument).

  2. Record something on the first track.

  3. Open the recorded part in a separate Key Editor window.

  4. Enable “Record in Editor” in Key Editor.

  5. Select the second track.

  6. Disable “Record in Editor”.

  7. Enable “Record in Editor”.

  8. Select the third track.

  9. Disable “Record in editor”. Observe that the second track is Record Enabled.

  10. Enable “Record in editor”.

  11. Select the fourth track.

  12. Disable “Record in editor”. Observe that the second and third track is Record Enabled.

  13. Enable Record in editor".

  14. Select fifth track.

  15. Disable “Record in editor”. Observe that track 2-4 is Record Enabled.

  16. Keep repeating the same pattern until you reach the final track.

  17. Have “Record in Editor” enabled.

  18. Delete the recorded content on first track.

  19. Observe that all tracks are now Record Enabled.

Expected behaviour: “Record in Editor” should not Record Enable previously selected tracks.

I encourage people to confirm this asap. if this cannot be reproduced, there might be another setting that requires enabling/disabling, so we’ll have to compare Preferences.

This is the cause of the behavior in the following thread:

I created this new thread since the old one is filled with inaccurate information. I will update that thread with a link to this one. That thread can also be closed by an admin or deleted, and leave this one open.

Best,

A

Hi,

Reported to Steinberg. Thank you.

1 Like

Hi,

Unfortunately I cannot reproduce it here on my side (macOS 13.1; Cubase 12.0.60).

Once I disable and re-enable the Record in Editor, the Instrument Track 01 becomes Record Enabled on my side.

I have the very same setup:

  • 10 Instrument Tracks (with No Instrument).
  • MIDI Part only at Instrument Track 01; the MIDI Part is selected.
  • The Preferences is set accordingly (Track Selection follows Event Selection = OFF; Enable Record on Selected MIDI Track = ON)

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Hello,

Steinberg Support already successfully reproduced the issue and added it to the bug backlog.