Record with arrager track Cubase 8.5.15

Ok, suppose you have a composition format A A B C (sonata form, for those in the know), and you use the arranger track to to repeat the A section. In Cubase 4, from which I upgraded, in record, the arranger would cause the repeat of A and move on, but the record operation would continue forward and result in a complete audio track which looks like A A B C - which I considered an ideal situation.
However, in the current Cubase 8, the record cursor jumps back to the A section along with the midi playback so that the resulting audio track looks like A B C.
I am hoping that there is some setting that makes it work like it used to in Cubase 4. I haven’t found it. Does anyone know how to make it work like it used to? Flattening it is a pain in the ***, and is contrary to to working classically from a score that looks as it should, i.e., with repeat bars.
Adding helpful new features is to be encouraged, but why screw up something that is just right to begin with?


Do I understand correct, the Arranger Mode is activated while recording?

On my system (8.5) the Record is switched to Playback after the very 1st A part.

My apologies Martin,
Yes you are right. When I saw the cursor go back over the recording instead of continuing on, I carelessly assumed it was re recording that section, and would go on to record the next section. Of course, this makes things even worse.
Is there any way to make it behave as Cubase 4 did, i.e., the playback cursor would follow the arranger track, and the recording would continue forward and record both of the A sections in order, and then the following sections as well?
Right now, my only options would appear to be:
Flattening the arranger - which is annoying because at the splice points the control sends are disrupted and I have to go and fool with them
Record to a third party app - in this case sound forge - which is also annoying because it requires that I reorganize my routing to look like the ‘what U hear’ function commonly found in cheap sound cards.

Recording from the arranger track worked so nicely in Cubase 4; I am surprised to see this odd change. I was really hoping that there is a new default setting which I could undo.