Recorded Midi is drifting way out of time when played

At first I though I was playing really badly recording over and over again but thought to myself I can’t be THAT bad when every time I record, even when taking my time following the metronome at 95bpm, it sounds great while playing in real time but when I hit the play button, everything goes downhill the further bars I listen to. The midi goes way out of timing and sounds terrible.

I know it’s not my playing because I launched Reason and tried recording the same thing with metronome and the timing was great just as I was hearing while recording. Please, any help is much appreciated. I’m halfway through this song and want to finish it up. BTW, when I recorded the first half of this song, I did not have this problem.

I’m probably venturing into a shifting sands area on that one, as I never had such an issue. But FWIW, few hints :

  • In the Studio Setup > MIDI Port Setup panel, I would check the different Devices options, as well as the Use system timestamp ones. Maybe someting doesn’t match with your actual setup, here…
  • is the Automatic MIDI Record Quantize involved, at a point ?
  • Any tempo variations in the project ? I would look more closely at the Musical/Linear time base setting chosen for the involved track, if so…

EDIT - Added to this, you could also try the usual Cubase troubleshooting attempt : relaunching Cubase as ‘safe mode’ with the Disable program preferences option.

I noticed it was only that track I was recording effected and not the rest of the song. So I made a new track with a new instrument and I had no drifting issues. Likely that effected track had a parameter set wrong by mistake or something. I will try to reproduce the issue to pinpoint it’s origin so I know what to look out for in the future. But for now, if the issue is only with one track, making a new one is best.

If you have high latency plug-ins on the track it becomes too tough to play right. Try the button constrain delay compensation and see if you can record better on the original track.