Recording 1 vst track but hearing other vst tracks on keyboard

Hello. I have an issue that i cant find an answer anywhere. So I have 1 vst instrument recorded enabled. But whenever I try to record that one track, Im hearing my other vst instrument playing at the same time whenever I play my keyboard. For example, instead of just hearing drums while recording on the keyboard, im hearing both drums and a synth sound that I chose while recording, every note I hit is playing the same for both instruments. Can anyone help?


Make sure the other Instrument track don’t have Monitor enabled, please.

But I want to hear the other track while recording on the new one. Is that not possible or something?

Remove your midi keyboard from the input of the other track or change to a different midi channel.

I dont understand why would i have to do this. I should be able to just click on the record enable track to hear JUST that track playing on my midi keyboard and not all other vst instruments, like any other DAW. This guy seems to do it at the 14:05 mark. . There is gotta be a way to do so.

As already suggested above. Disable monitor from the already recorded track.

But I want to hear the track so i can play along to it. I’m seeing several videos where monitor is disabled, but they are still able to play along with other recorded vst instruments while recording on a new.

Already answered in your other thread.
Can you please stick to not creating multiple threads about the same question.

Ok I’ll stick to the other thread, but that answer different solve anything unfortunately