Recording Arpache 5 output to MIDI track

Yes I know that the first thing people will say is search for this since it’s been answered already. The thing is, it hasn’t been. At least the solutions I’ve looked at so far have not worked.

The solution seems to be to use MIDI merge in loop. This doesn’t work for me. It does produce a MIDI event on that track, but it isn’t at all accurate, meaning it isn’t even close to the same notes that would be playing if I just let the track run with Arpache on. And yes, I have the track solo. It starts off alright but quickly starts producing erroneous notes. It really isn’t useable.

I was able to accomplish this by creating another track and setting the MIDI input as the output from the other track, but this only seems to work with certain random VST’s… it doesn’t work for everything, as it appears not everything outputs MIDI. So again, this doesn’t always work.

The other thing is this button in the MIDI inserts inspector to “record output to track” which I can’t for the life of me figure out how to get to work. I’ve seen the Steinberg page saying how this should work but for me it just doesn’t. All it ends up doing is playing the original MIDI as though the insert has been bypassed and records absolutely nothing.

So my question stands… how do you reliably do this? Because it’s actually seeming pretty ridiculous to me that this is so hard.


“record output to track” is the trick.


I literally just said that that didn’t work for me and described why. Do you have any more thoughts on that?

At what point are you applying the Arpache, before or after recording the part?

Please be more specific what you are doing. Then we can find, why it doesn’t work to you.

Does it actually matter, as far as Cubase is concerned? If so, that’s pretty weird (i.e. incredibly undesirable). I’ve got a MIDI track with Arpache 5 on it as a MIDI insert. There are notes I’ve drawn in on that track, which are obviously being arpeggiated by Arpache.

Honestly, I don’t know how much more specific I can be than I already have been. I’ve got a MIDI track. With Arpache on it as a MIDI insert. That’s what I’m doing. I want to render or otherwise record the notes coming out of Arpache.

“Record output to track” works as intended. Arm a MIDI track, record, play, and the notes produced by Arpache 5 are recorded onto the MIDI track. I can then bypass or remove the Arpache 5 insert and when I play the track, I hear exactly what I heard when I recorded it in realtime.

But if you won’t tell us what you’re doing to cause it to not work for you, we won’t be able to help you fix it.

Is it the only one Insert effect? Or is there any other Insert effect before in the chain? If there is any Insert effect before, isn’t it bypassed? Is it also in to Record mode? Is your Arpache 5 Insert plug-in enabled?

Faulty logic here. How do I know what I’m causing it to do to not work if it has never worked for me. This very statement presumes that I already know what variable causes it to work or not work, in which case why would I be asking the question?

I have tried any number of different things. It only works when I’m actually playing MIDI into it. Routing MIDI into it does nothing, under any circumstances.

Yes, only one insert. It’s not bypassed. It is in record mode. Yes, it is enabled.

The only time it will record the output to track is if I’m actually playing (live) MIDI into the track via a keyboard or something. If there is existing MIDI it does nothing.


This is correct. The feature is specified like this. If you play live and enable this button, the data with the Insert effect applied is recorded. But you can’t record it from the track with the applied Insert effect to the track back. You could export it as a MIDI data, and import it back. That would work of course.

The problem, and the whole reason I got into this mess, is that neither Export nor the Merge function produce output that is like what I actually hear with Arpache running. I really don’t know why this is, but it’s annoying. Sometimes it vaguely resembles what it should, but then I’ll have stray notes going all over the place. For instance, just having a bass line, where I hold single notes and have Arpache playing a sequence of 1/16 notes at those pitches should be fairly simple, but in the Exported or Merged versions, I will end up with octave transpositions at odd rhythms, the changes not starting where they should, etc. I really have no way of accounting for why it would do this but it’s consistently wrong.

Bumping this old thread, have the same problem here now.
Anyone solved it?


If you want to record the arpeggio to the track, enable the Record Output to Track button in the MIDI Inserts, please.

1 Like

For anyone still searching on this topic: i think what the OP meant to do, is to not play live, but have the arpache 5 do the arpeggio AFTER the initial midi recording. So you end up with a midi part, that is being arpeggiated by Arpache 5 when you hit playback. In this situation the record enable button does not work at all. Instead, you choose “Freeze midi modifiers” from the MIDI dropdown menu.

Hope this helps someone in the future.
All the best,


1 Like