Recording Direct Guitar Signal

Hi, I am new to Cubase. I’m trying change from Logic because I want to change to PC in the future.
I want to record direct guitar signal into Cubase but it is not picking up any signal. The input signal on the Interface (Komplete 6) is showing, but Cubase is not picking anything up.
Everything still works perfectly fine on Logic so I must be doing something wrong with the set up of Cubase.
I’ve attached some pictures to show my settings.
Screenshot 2017-05-16 12.12.59.png
Screenshot 2017-05-16 12.13.08.jpg
Screenshot 2017-05-16 12.13.19.jpg

one more picture
Screenshot 2017-05-16 12.13.19.jpg

VST System Link is for synchronizing two devices. If your not doing that, you should have “not connected” on that page. I don’t know if that would fix your issue though.
I am not smart on synchronizing two DAWs or devices but maybe having something selected there that is not actually a clock signal causes Cubase to “sit still”.

The connections for your guitar are mono. You have (I assume) the front two connections setup as one stereo bus. Try creating new buses for these connections again and assign them to be separate mono buses. And make sure to choose the one you are connected to for your audio track.

You didn’t show it so I am assuming that your audio interface is chosen in the VST Audio System menu and that the main stereo out bus is set correctly.

Also… fyi, if this helps to get you going, don’t forget to disable the track monitor function to hear what you recorded.

Regards :sunglasses:

Hi, I still cannot get any signal from my guitar. Are there any other screenshots I can show to see whether if I set things up correctly. Sorry I’m very new to Cubase.
Screenshot 2017-05-18 21.29.19.jpg
Screenshot 2017-05-18 21.29.29.jpg
Screenshot 2017-05-18 21.29.38.png

I am assuming that you are plugging your guitar into one of the connections found on the front of the Komplete 6. If not, that is where you should be plugging it in.

Based on you screen shots I would do this…

  • Go into the VST connections input tab and delete all of the buses.
  • Hit the “add bus” button and create a new separate mono bus for the front (Input 1 L) connection and for the front (Input 2 R) connection. You should now have 2 separate mono buses.
  • Go into the VST connections output tab and delete the guitar mono bus.
  • Plug your guitar into the front (Input 1 L) connection.
  • Open or create a new audio track. It can be either a mono or stereo audio track.
  • Set the input for that audio track to be the front (Input 1 L) bus.
  • Set the output to be the Main Stereo Out bus.
  • Make sure your speakers (or monitors) are connected to the Main Output L & R connections.
  • Press the track record enable and monitor functions (the monitor function is the button that looks like a speaker just to the right of the record enable button). Adjust the sound level on the front of your interface and in the Cubase mixer to hear your guitar through the speakers or through headphones (I recommend headphones).
  • If that is working then hit the record button on the transport bar and record something.
  • When you want to play back that recording you must disable the track record enable and monitor functions.

Hopefully you are all set. If not, feel free to ask for more assist and post a shot of the VST Audio System screen.

Regards :sunglasses:

Hi, Thanks for the help! I still don’t get any input signal on the audio track. The Input 1 on my audio interface is lighting up. And yes, I’m plugging my guitar into the front of Komplete 6. Also, sometimes when I hit recording I get “Recording Error " ASIO driver not running”
Screenshot 2017-05-19 10.47.07.jpg
Screenshot 2017-05-19 10.45.08.png

Need a screenshot of the VST Audio System which is the menu one above what you posted.

Regards :sunglasses:

Here :slight_smile:
Screenshot 2017-05-19 13.01.54.jpg

Have you checked if you can play any audio in Cubase using the Komplete?

Also…
jaslan posted this a few posts back. I don’t think you answered his suggestion. So unless you are connecting two devices you should change this setting in the VST System Link menu (ASIO Input & ASIO Output fields) to “Not connected”.

Regards

No, I tried playing some wav file on the audio track and no sound. I think I’m just setting up the Komplete wrong or there is something to do with the driver

And I’ve changed those to “not connected”.

PS, no clicking sound from the metronome either. So I guess its something to do with Komplete. Because everything is fine when I just use the Built-In Output.

What version OS are you running?

This won’t help the ASIO driver errors but I want to make sure you are enabling the track monitor function to hear yourself while playing and then disabling it when playing back. I ask because none of your screenshots show the track monitor function button “not” enabled.

Edited to add the word "not"

Regards. :sunglasses:

I’m running El Capitan 10.11.6. I think it has to do with the my set up with Komplete 6 and Cubase. However, I don’t think there’s any issue with Komplete itself because it still works fine with Logic.

Maybe it is something to do with ASIO error. Is there a way to fix that?

Try this:

https://www.steinberg.net/forums/viewtopic.php?f=226&t=87138&start=175#p494377

Or maybe this:

https://www.native-instruments.com/forum/threads/komplete-audio-6-does-not-work-under-el-capitan.265010/

Note however that there are known problems with KA6 on El Capitan so even if you get it working you may still experience drop-outs or poor performance.

I don’t think it’s something to do with Komplete and the OS because it still works fine on Logic and everything. Only Cubase than I’m having problems with.

Your last posted VST Connections still looks wrong to me. You have an output bus “Guitar -3L” or so.
You need a mono input bus, input 1, or whichever input the guitar is plugged into, and you need a stereo output bus for the “Main Output” (whichever outputs on the KA6 are designated for the monitors). The guitar audio track should have the mono guitar bus as it’s input and the Stereo main output bus as its output. Make sure the monitor button for the track is turned on (or record arm).

I’ve done that. The problem is that I can’t even get any sound to play from Cubase (wav audio files, even the click tracks). And the main output is the Stereo main output. My guitar is plugged into Input 1 on Komplete
Screenshot 2017-05-21 11.52.43.jpg
Screenshot 2017-05-21 11.52.51.jpg