Recording External Instrument but no audio

Dear Cubase Team,

It all started when I rendered (render in place) a couple of loops to audio, which worked fine.
Up to the point where I wanted to render a selection but upon real time recording of the loop it recorded only silence. I proceeded to record some automation, but something did not work so I deleted the automation again. Since then my external instrument is silent upon playback of midi data (though recording midi works and I can hear the synth when playing the keys).
When I open a new project and try to use said synth I now have the same problem; although I have recorded this synth in the past without any problems. I don’t know what’s going on.

Thanks in advance.


Is the MIDI Output set correctly in the MIDI Device Manager ?
And is the right MIDI Device selected for the External Instrument ?

yes to both questions - also, it has already worked perfectly in the past

I have no idea why this worked but…
I deleted the configured midi device as well as the external instrument and repeated the “normal” setup process: install new midi device (Midi Device Manager) and then re-configure the settings under External Instruments (audio interface, ports, and associated midi device).
Let this be said, for some reason that escapes me, it did not work on the first time, I repeated this process several times until it suddenly worked again. I have absolutely no idea what that was or if it might happen again?