Recording in Cubase

Hi, not used Cubase for a few weeks, launched it today to do some recording, I have Focusrite Scarlett 2i2. I can not get Cubase to either record or playback in Stereo. tried resetting everything, downloaded latest driver for focusrite…deleted inputs and outputs and reset everything but still only plays back in one channel, has anyone any ideas what I am doing wrong???
Many thanks

Several usual things to check first :

  1. Do you have an actual audio processing load (Studio>Audio performance menu option) ? This, just to iron out any issue between Cubase and your audio device driver…

  2. Routing check :

    • If audio, one of the inputs defined in the Audio connection window should be used in the Input routing drop down box of the track inspector. Just for trouble shooting purposes, I would disable everything eventually related to Direct monitoring, both in Cubase and in your audio device settings. In the same league, I would try to tick/untick the Release Driver when application is in background option (Studio setup>Audio system pane) : I have some issues with this one, Cubase sometimes not making connection with the driver at the beginning of a session, because of it. Check also the Output routing drop down box : normally, it should point either to the main output, or an eventual group track.
    • If MIDI, one of the port defined in the Studio setup window - MIDI Port setup pane, should be used. Normally, the channel number used isn’t critical, unless you have VSTis specifically set to receive data only on a given one. Set also the MIDI channel to ‘Any’, just in case. Check also the Output routing drop down box : it should either point to a VSTi available and loaded, or to a MIDI output port of your audio/MIDI device, also defined in the Studio setup window.
  3. Actual signals receiving check :

    • If audio, be sure of both the Gain value and the fader position - same thing for the eventual corresponding Input channels (Cubase Pro - I don’t remember how this is done in others Cubase versions).
    • If MIDI, be sure that MIDI data is actually received (using the Input/Output activity component of the Transport bar).
  4. Be sure that at least, the track used is record armed (Record button lit for the used track).

Now, about the one channel playback, there is something fishy, here. An usual information would be, first, to know if you are using any mono tracks.

Beside this, check again all the audio connections to be sure that, at least, the outputs are defined as stereo pairs. Additionaly, are you sure of your pan settings and about the way eventual FX inserts are processing your signal chain ? FWIW, I use several mono tracks as audio input but always get a balanced audio output signal, as all my outputs are defined as stereo.

After this, I’m afraid that I can’t think of something more, at the moment. HTWH, though…