Recording levels from VST Performer 5.6

Hi all,
I’ve got VST Connect Pro and VST Performer finallyt working well enough.

Our issue now is two rather crucial things:

ONE: The Gain Level of the recordings is VERY LOW. Despite turning up the gain on the microphone (a Shure SM58) and an electric guitar DI in the mixer ( a Presonus Live with USB drivers, 16 channels also via USB), the levels are extremely low. The Main fader is also up to the maximum as it affects the levels going to USB.

In the VST Connect mix window I am only getting levels in the meters up to about the 2nd marker from the bottom, sometimes up to the 4th line.

When I am using the talkback, the levels go all the way up to about the 3rd line on the meters from the maximum. A BIG DIFFERENCE!

The issue is that once I record if I need the client to listen back, I have to crank up the Cue sens on each channel, as well as max the fader and even use a Gain processor to gain up the audio files by 10dB before they could hear it ok to overdub to. That is a ton of work!

What could possible be going on?

Issue TWO: When Nuendo is stopped, I can hear the incoming audio clean and clearly. And loud enough to be able to communicate with the talent. The meters also work in Nuendo’s Control Room, and in the VST Connect mix section.

However, once I press RECORD, all sound STOPS coming in!!! And the meters stop working! Is this normal operation? Also, the SYNC light goes from green to red on the Connect side of things, and it only put up a few filed on the Timeline, maybe the first three tiems, and then it does not put them up any longer. I have to manually move them onto tracks after recording. Is this normal behavior?

My streaming settings are all a 256K up and down, the audio setting is 24 bit 96khz 9not sure what the mixer is doing, the client does not know if that can be changed on their end.) Also the IO buffer setting is 512k, not changeable. I have fiber network at 500mD up / down, and my client has also land ethernet, although I am not sure of the speed, I’ll have to ask.

Any ideas to make the recording gain louder and to be able to listen while Nuendo is actually recording?


VST Connect makes no changes to gain.

You should look at the meters of the Performer Mixer Input channels. There are two of those, one shows the direct input of the Performers’ hardware. If this doesn’t show sufficient level, there simply is none supplied to the VST Connect Performer program.

We don’t know what systems are used on either end (Mac/Windows), but in any case you must make sure that Performer has his audio interface gain and input(s) set up correctly and for sufficient level.

There is no need to crank up any faders on your (Studio) end either. The Cue mix is a regular mix that applies with or without VST Connect. If you record somebody next room using Control Room and cueing, that’s all the same as when using it with VST Connect!

From Performer to Studio: make sure the red levels on the Performer Input Channel(s) are ok. You cannot influence those at all, they represent the pure, raw input signal from the Performers’ hardware, so if those are too low, you must have the Performer to resolve it, there is nothing we can do about it, as we have no access to the Performers’ hardware gain settings.

Note that the faders are for the Performer’s monitoring only! Those do not make any difference for what Studio receives (records, and hears). Also we strongly suggest to set all levels to 0dB in the first place, and start from there.

From Studio to Performer: watch the Cue meters. The Cue meter in the VST Connect plugin is linked to that of the VST Connect Cue Channel in the Control room. If those don’t show sufficient level, you need to adjust cue sends in the mixer, and/or the VSt Connect plugin “To Perf” level, which again is linked to the Control Room VST Connect Cue channel level.

Let me repeat that all of this has nothing to do with VST Connect in the first place; this is a regular Control Room Cue channel, and if the meters barely move, a person to be recorded next door wouldn’t hear anything (or too few) either.

Try to raise the “Remote Latency” setting in the VST Connect plugin (settings, cogwheel). It is vital for proper sync. When you start Nuendo transport, there is a delay until it actually starts in the Studio. During this time, playback is sent to the Performer, the Performer performs and sends his data back to the Studio, so that they are available when the transport actually starts in the Studio after said delay time. If this amount of time is insufficient to send signals to and fro, due to network latency, you need to raise the “Remote Latency” setting. Raise it to 2 or 3 seconds and check if it works then.

If that still doesn’t work, you may want to check both of your network connections. Speed is usually not of concern, but quality certainly is! Your internet speed test will usually not tell you how many packets are lost or other metrics of connection reliability. Do not use WiFi, or phone tethering, use cable connections on both ends.

There is a lot of good explanations and recommendations here, check it out.

Thanks musicullum.

On the performer’s end, we turned up his mic gain to the maximum, to where it was clearly distorting the mixer he is using, but it feeds the USB output still very low to my end. There may be an issue inside his computer then, as it is Windows, and sometimes they have this awful software mixer that screws everything up.

I had the performer turn the mic level back down until there was zero distortion. I’ll try to see if they know enough about their computer for me to have them check any internal Windows mixer (Windows 10 professional) that may be turned down.

And thanks about the “Remote Latency” inside VST Performer, I’ll turn that up from the 1.5 seconds it is now, and see if it gets better.

I did check that troubleshooting page. The only setting that I had on and turned off was ASIO guard. I’ll see later in the week if this makes a difference, it should.


I did a test session with a buddy, and everything worked quite easily and quickly, and the recording levels were much better, And then I did a test session with the home studio where a client is going to be recorded, and it again worked very well, very quickly. They were using a Mac with High Sierra, and an Onyx 24 USB mixer. I was able to help set levels for all 16 tracks, and record and then import them into my DAW without much issue. A test recording of nearly 6 minutes 16 tracks at 44.1/24 bits took nearly ten minutes to transfer.

So, I am suspecting the hardware and / or the computer at my friend’s house. It’s an older Presonus 16 track USB mixer, and a computer he is not quite familiar with. That, along with at least one mic cable that we were finding was not working properly, led me to just not attempt any more remote recordings from his home studio, at least not until those issues are resolved.