Recording MIDI = everything is in advance

Title says it all. When I playback MIDI recorded notes, they are all playing in advance from the grid.

I tried ticking the “timestamp” boxes in the Devices menu and checked/upodatd all drivers from my keyboard and soundcard, all fine but didn’t solve the issue.

Is there anyone experiencing this or can anyone suggest a workaround? Because it’s really annoying having to select all the notes from EACH take and move them a bit forward everytime I record…

Thank you!

C8 Pro
Win7 64 Ultimate
RME FireFace400

I’ve also got this problem.

This is a screenshot from a midi recording (running in 100 bpm) where I’m trying to play as accurate as possible. Sounded good when I recorded but as you can see it didn’t turn out so good.

I’ve tried all the settings I could come up with like constrain delay compensation, asio guard, midi timestamp and what not but it makes no difference.

Absolutely, I had the exact same problem.
I was wondering if it was me but it obviously wasn’t, I’m glad I’m not the only one having this issue.
And yes, and you mentioned the zero latency option doesn’t help.

I also get this issue, have for a long time. In fact, I can’t remember getting relative MIDI accuracy since pre MIDI Audio days when Cubase, Logic etc where designed to sequence external synths and samplers. Maybe it’s got worse over the years as modern DAWs have become more bloated, dunno :confused:

Or maybe my playing has got poorer…? But I have to edit everything after playing it even with auto quantize on.

I just live with it but if there’s a way to improve the situation I’m all ears, and fingers :slight_smile:

Noticed the same thing yesterday. MIDI data from my Cirklon (which is synced to Cubase with a SyncGen Pro) is ‘recorded’ early. Jitter is low, but data is recorded early. I need to check if this is related to Delay Compensation though, and if the amount of time the data is recorded earlier is consistent between takes.



Edit: Actually I just checked and found that auto quantize hasn’t been on since Cubase 8. That should hopefully improve matters. They seem to have hidden the auto quantize button in CB 8

Auto quantizing will have the same result as quantizing after the performance, which will result in inaccurate note snapping.
I never used auto quantizing as I don’t want all the notes to be on the grid all the time, I usually just select the ones I want to quantize and do it.
But this is a different matter, we are talking about some kind of “negative latency” that makes all the notes playback in advance vs what we actually played while hearing the click/music/whatever .

It would be really nice to have someone from Steinberg replying and see if they acknowledged this issue or not.

Well I sure didn’t have this problem in Cubase 7 so I’m thinking there might be some setting that I’ve overlooked.

Yeah, auto-quantizing is not ideal. I use insane amounts of swing on the Cirklon, so auto-quantize would mess with that. Let’s see if Steinberg responds to this, I did not have this in C7 either.

Ok, so now my problem is gone. The thing that made the difference was that I went into the Midi Port Setup in the device setup and pressed the Reset button.

Time will tell if this really was the source of the problem but for now midi records just fine.

Ok thank you, I might try that and let you know if it solves the problem !

Yes thanks, will try that too!

I like to get the notes as close as possible on grid to begin with and then add or program any groove element I want after. I rarely find any useful groove or swing in random and unexpected off grid notes, though it could happen I guess, in a serendipitous way.

Ok I tried to reset the MIDI and it didn’t work…did it work for you characterstudios ?

Ok, but how about the record midi settings? Here’s mine:

All the same except I didn’t have ASIO Latency Compensation Active by Default ticked…I tried ticking it and nothing changed.

Ok, then I guess the only thing left to try (with this stuff anyways) is for you to reset your midi ports having the “ASIO Latency Compensation Active by Default” checked.

You could try removing the ignoreportfilter file. Create a folder within and stick it in there so you don’t lose it should you want to replace it.

Program files>Steinberg>midi port enabler

I seem to remember this having an effect in an earlier version. If it doesn’t work it is easily replaced.

It’s very subtle, I think I’ll have to try with more recording tests but I think it works now :slight_smile:

Thank you LarsErik !!

You’re welcome.