Recording Midi (Volume?)

Hi folks,

I have a basic question which has been puzzling me for a while now. I have checked the forum but could not see a thread relating to this directly or simplistically.

If (as I always do) I record a MIDI TRACK using an external keyboard to play the notes into Cubase (ie. the Midi Data then appears in the ‘piano roll’), does it actually matter what the FADER LEVEL is set at (in the F3 mixer) ?? By default, the mixer (white) fader is all the way down at zero (though the green lights show incoming data regardless of this). Then if I move the (white) fader, it ‘snaps’ and takes control of the level of the incoming data (ie. the green lights for the Midi Track will flash more/less depending where the fader is positioned).

Now, is this VOLUME which is being represented in the Midi Track (F3) mixer ?? And more importantly, regardless of whether or not it is, does it matter where the fader is set, or if it is at its zero position ?? As I say, in default, the incoming level (green lights) is high.

So, what my question is leading to is that :-

After I have recorded the Midi Track (via my external keyboard), I then create an Audio Track and play back the Midi Track (which in turn triggers the internal sound on my external keyboard) and record the sound from the external keyboard onto the Audio Track in Cubase. In other words, I have a Midi Track and Audio Track versions of the same thing. No problem.

Anyway, the problem is that I have been getting a lot of ‘clipping’ and I can only assume that this may be related to the aforementioned regarding the level of the Midi Track (green lights) ?? Does this actually record the VOLUME (in Midi language) and then (if set too high) will cause the incoming Audio Track to distort ??

I hope I have explained this ok. Its not too complicated a question. It’s just a little bit tricky to explain in short.

I have a short excerpt (on the Yamaha forum I use for FM Synth topics) where you can here this unwanted effect. Its only now again that you can hear the individual clipping sounds but they are noticeable. Sadly, I have now noticed in in other recordings I have made previously ! I thought it was maybe ‘Automation’ (pitch-bend and Mod Wheel) which I record separately over the Midi Track (and then ‘glue’ it), but I am not sure if this is the case ??

http://www.yamahaforums.co.uk/forum/pos … =35&t=6189

Many thanks in advance…

Best,

Paul

Hi Paul -

To get rid of the clipping …

I’d guess the clipping would be from your interface’s input trim/volume being too high as it receives the audio from your keyboard, and can be adjusted best with adjusting the interface control.

I have a similar recording chain, and keep my keyboard synth volume fader all the way up.

Hope that helps!

Hi Alexis.

Thanks for your reply.

I have my synth volume slider 80% high. And the CI2+ ‘trims’ at 12 o’clock (so only about half way up) and so the ‘peak’ red LED’s never come on.

However, I have had a bit of a problem recently with experiencing ‘clipping’ in general. Often when I just play an mp3 or play something on Soundcloud I think I can hear bits of clipping. I had my computer health-checked last week at the shop where I bought it, and also Dell took remote-access on Friday for an hour and found absolutely nothing wrong with it whatsoever.

I am wondering if my Buffer sizes are set as they should be. For the past couple of weeks I have been experimenting with A/V software to try and make some videos to put on You Tube etc. I have sorted out the Latency issues I was having (using Cubase and an external synth thru the visual/audio capture softwares) but the issue with ‘clipping’ remains. I thought that altering the Latency would automatically correct the pops&cracks but this does not seem to be the case.

The settings I had changed were ASIO Full Duplex and ASIO Low Latency. Though I only did these ones this evening and the problem has been happening a fortnight.

I would be happy to pay someone some beer money towards their time if they were able to sort it. I can Skype/Team Viewer (monsterjazzlicks) as I have 2 x PC’s. Its driving me mad as its interfering with all my recordings now and I have spent 2 x weeks on this single issue.

Ta,

Paul

It might be worth going back to basics to efficiently trouble shoot …

Record one keyboard out via MIDI to Cubase MIDI track in to Keyboard in to Keyboard out via Audio to Cubase Audio track in. New project, no plug-ins, etc, especially on the master channel.

Do you hear “clipping”?

If so use your meter “input” and “post pan/post fader” output views on all audio channels (two of them in this case) … make sure there’s nothing close to 0 dBFS.

If you still hear clipping it might be speakers, or interface audio out issues. Or something else, but at least you’ll have eliminated gain staging issues as a potential cause.

PS - could not open your link …

Sorry, let me post it up on Soundcloud. Only members of the Yamaha site can view/download. My error !!

There you go Alex :-

https://soundcloud.com/monsterjazzlicks/trane-in-3-seaman

Its not the clearest of examples put there are ‘pops’ at 03, 07, 40 and at the end.

That’s not clipping , that is pop and clicks from interrupted audio stream. What’s your audio interface, what ASIO driver is selected , and what buffer size have you selected in the driver.? Don’t use the ASIO Full Duplex and ASIO Low Latency use the real driver that your interface came with.

Thanks a lot Peakea.

I have been quite worried about this. You did very well to spot the problem with only a few tiny examples. I should have made a longer recording but anyway you have sussed it out.

I only tried Low Latency and Full Duplex tonight out of desperation!! I have always used the Steinberg Yamaha ASIO drivers for my CI2± interface. But I had some stupid problem causing software removed a couple of weeks ago (Tune Up Utilities) which altered many Steinberg settings. Perhaps this caused some unwanted changes?

Best,

Paul

Hi,
Sounds like you might be onto a fix…

But my question is as your original question was put forth. Mainly, what in fact does the MIDI fader do? As you note it is set by default to zero and from there increasing it seems to have some strange effects. Certainly there is not much gain in volume… I have wondered about this for a long, long time.

Thanks,
LB

Thanks for re-raising the original question.

Hi again Peakae,

The Buffer size for my Yamaha Steinberg CI2+ is the default ‘512’ setting. However, there is a NEWER driver update available (I was unaware until just now) from v.7.3 to v.8.3. But the Steinberg site (shop/products) is down at the moment (maybe ‘maintenance’ work) ?

I am hoping such an update will cure any such bugs. :bulb:

Ta,

Paul

Yes, try that , and best of luck.

I don’t think I have noticed the problem on my Win8.1 PC. Only on my Win7. :neutral_face:

Are you muting the MIDI track after rendering audio as you should? Otherwise both will play.

Hi Gump,

Once the Midi Track had been recorded, and then in turn played back and recorded as Audio, the Midi Track is either muted or permanently deleted (depending on the Project).

Ta,

Paul

When you render, did you try Realtime? What plugs are used during render?

Hi Paul.

Just FYI, make sure you don’t go crazy looking for the solution to this.

I’ve been noticing Cubase 7.5 clipping into the red at any given time. And I’m very vigilant about my levels.

I’ll have a song of about 12 MIDI tacks driving some VSTs, and all of a sudden there will be crackles & pops & then nothing again for an indefinite amount of time. Upon playing the song again it’ll be fine for any number of run-throughs.
[I’ve made sure that it isn’t the fridge, freezer or A/C kickin’ in & out when this happens.]

Often, the clicks that push the main levels into the red are not even audible, and yet they appear.

I know this doesn’t come across as good news, nor as any type of helpful solution, but I just don’t want you pullin’ your hair out if you can’t find a fix for it.

Know that at least one other is having similar issues. [We’re not using the same audio interfaces.]

Hi Jamusic,

Oh really? This is the AUDIO tracks you are referring to? (ie. you just leave the MIDI fader level at zero/default whist recording?).


Oh dear. That a shame for you and I know how much it really interferes with one’s ‘creativity’. I was wondering if it might just be my ‘processors’ capabilities because I don’t think I experience this on my Win8.1 PC (just on my Win7)? Though I have only really started to notice this over the past few weeks (unless its just that my ‘ears’ are getting better !! lol).


Mmm, that’s a weird one. :nerd:


Thanks for your reply. I am always open to ideas. I do hope you manage to get it sorted for yourself. Have you tried playing your projects on another PC?


I see you are also on Win7(64). Which Interface do you have? Would using a super duper interface cure the issue do you think? Could this UR22 be something which is a substitute for the (my) CI2+, or is it a completely different device? :-

http://www.steinberg.net/en/products/audio_interfaces/ur_series/models/ur22.html

I managed to download the v.8.3 Steinberg Interface drivers tonight. I have installed them on both PC’s but not tried them out yet. I was only on v.7.3 and it said that the update was designed to fix Latency bugs amongst other things. It also prompted other automatic updates to my Steinberg software so I must have been quite behind.

Just a shot in the dark, but would RAM size help with this? I have 4BG in my Win7 and 8GB in my Win.8.1. Both RAM capacities can be doubled if so desired. :bulb:

Best,

Paul

Sorry Gump, not quite sure what you mean exactly dude (my wrong)? Is RealTime a plugin tool for this process?

It is midi volume.
Go to your midi track inserts and insert the midi monitor. Play your midi part back & move the fader - you’ll see the volume CC’s displayed in the midi monitor. However, if you don’t move the fader, what you are seeing in terms of the “pulses” is a midi event - usually the note velocity if you’re just watching the playback. Try playing a few notes, go into key edit & draw a velocity ramp. Play back the midi part and watch the values in the midi fader change to their max value.
Personally I never or rarely display midi tracks in my mixer. I use the filter to turn off the midi channel in the mixer. It saves a lot of mixer clutter & gives you more “real estate”.
If you do keep the midi tracks displayed, I’d be tempted to leave the faders at zero. After all, you’re probably and most likely going to mix through the instrument tracks anyway
Hope that helps
Neil