Recording multiple inputs to separate channels troubleshoot

First post :3 I’ve had this problem for years but I can’t be bothered to solve it because I’ve been content overdubbing, but now I really want to record dual inputs simultaneously and have them come out separate channels in the mix. Sounds simple, right? What am I doing wrong?

Software: Cubause AI4
Hardware: Yamaha Audiogram 3 (simple audio interface; two inputs (1 and 2), ‘1’ is a mic/ 1/4" input, ‘2’ has L and R 1/4" inputs. Picture: http://www.chappellofbondstreet.co.uk/sites/chappellv3.17/productimages/big/YAM-AUDIOGRAM3.jpg

In Cubase, I have tried setting up two mono in buses and two mono out buses, and assigning each to separate inputs/outputs on the device (Mono In, Mono In 2; Mono Out, Mono Out 2). I have then created two mono audio tracks, and assigned each to their respective buses.

When I plug an instrument into input 1 and another instrument into input 2 (the L input of input 2), the signals seem come out on separate channels in the headphones. However, when I click the monitor button in Cubase both signals come out both channels, and when I record the same thing happens.

I have tried just about every other possible combination of a) buses for both inputs and outputs (including stereo ones), b) ways of assigning tracks and and c) ways of connecting to the Audiogram (including using the L and R channels of just Input 2). Admittedly I don’t know much about it and there is probably something very simple I’m doing wrong.

This sort of thing has been asked a million times before, but I’m sick of sifting through forums :cry:
Thanks in advance!

Assumption:
You want instrument 1 to be on the left channel of your headphones.
You want instrument 2 to be on the right channel of your headphones.

Assuming this, do this:

  1. Create two mono input busses and one stereo output bus
  2. Record the instruments onto mono tracks, route output to stereo out bus
  3. Pan the tracks hard left and hard right (respectively)
  4. Track panned hard left will be on left of stereo, track panned hard right will be on right of stereo

Hope this helps

Unfortunately, this doesn’t help :frowning: I did suspect that I needed a Stereo output bus, but I had tried that before.

When I pan the two tracks far left and far right, I still get exactly the same thing in both channels – because both tracks have recorded the same thing (this is obvious from the err… illustration of the soundwaves, or whatever it’s called. Both tracks look identical.)

Maybe it’s the Yamaha Audiogram interface… I notice that anything plugged into input 1 comes out stereo (even with mono input and output panned hard), whereas if instruments are plugged into both the Left and Right inputs of input 2, they come out in the correct channels in the headphones, but nothing shows up in Cubase for the Right input (only for the Left).

I’m bamboozled.

[Add. info: So what I’m saying is that even to record two inputs in a single audio track, I need to plug one into Input 1 and the other into the Left input of Input 2. Input 1 is always stereo; while nothing ever records (or monitors) from the right channel of Input 2, though I can hear the signal from that input just fine.]

What Shinta215 explained should have done the trick. So the problem must be with the hardware setup. try plugging in both input into the “2” Input section, switch it to “Stereo” if there is a switch or button for that and set the appropriate VST connections in Cubase. Make sure there is a “Stereo Out” in the the output connections and route your tracks to that. This is how it should look:

[Hardware] [Software] [Tracks] [Output]
Input 1 -> Mono Input Bus 1 -> Track 1 -> Stereo Out 1
Input 2 -> Mono Input Bus 2 -> Track 2 -> Stereo Out 1

Each track’s input should be routed from separate input buses and their outputs to the same stereo output

[–EDIT–]

You can have two inputs record on one track, but that would make things more complicated especially if you plan on adding effects. It’s also the best idea just to keep them on separate tracks so they are easier to work with.

-_- I have no idea why it doesn’t work.

It seems like it should be too easy.

There is no stereo switch.

I set up the buses right, but there seems to be no way of making the buses and the Yamaha interface respect one another. No matter what input I use, everything winds up on the same track. Maybe the interface itself is defective lol.

It must be something simple you are doing wrong.

Could you post screenshots of the input/output connections and a screenshot of the channel settings?

VST connections.jpg
Channels.jpg
Is this what you want?

I’ll be glad to be made a fool of, I just wanna get recording… thanks for bothering.

Install the ASIO driver for that yamaha interface and change to that from the directX driver. The directX driver is rubbish, it may not even be able to use more than 1 input simultaneously.

VICTORY!

Had to download that from their site… dunno why it didn’t come with it. Never wudda guessed I had to do that.

Now records separate things from the L and R plugs of Input 2, and Input 1 is still recording over the top of everything (I made a 3rd mono bus, but it seems there aren’t enough USB Audio Codecs to assign a new one to it. loliknownothing).

Thanks to everyone! :smiley:

Nice :slight_smile:
Now post some recordings in the made with Cubase forums :sunglasses: