Recording Using Profire610

In WL 6 I quite often record ideas on the fly by either playing the guitar through a softamp, or playing keyboards using Akoustic piano B4 or whatever and recording the sound coming out of the speakers plus the vocal back into WL using one or two mics, simple. I prefer this to Ableton, Cubase or PT for this roughing of ideas. In WL 6 I just set the levels and sr/bd and press record.

In WL 7 i get this.
WL7 Problem.JPG
Which is pretty much a showstopper. If I close WL7 and open WL6 everything is ok. On a positive note there are a lot of things that are good in the tabbed layout, hopefully this will be incorporated in CB6 to stop the annoying window resizing, but back to WL7, is there something I’ve missed here?

Anyone?

This message is the sign that the audio device is not properly set in the Audio Streaming Preferences (Options menu > Recording tab)

I have tried all the different settings with WL7 on it’s own and all is working fine. When I open Akoustic Piano I cannot record.

In WL6 I can open Akoustic Piano and record it and a mic input together, I can change the sample rate and bit depth and still have no problems.

I have since discovered that if I change to 44.1/24 in WL7 I don’t get the pop up screen, but pressing record has no effect. The samplerate of Akoustic piano is set at 96K.

Did you try MME also? Can you show your recording settings (picture)

That was quick! MME works fine. Can you clarify what recording settings you want. Thanks

Audio Streaming Preferences > Recording tab

WL7 Recording Settings.JPG
This perhaps?

When I hit refresh the M-Audio Profire vanished and was replaced by Wndows MME, and I no longer have that option in the upper drop down as per this
Recording 2.JPG
The other choice being Microsoft Sound Mapper in the lower box.

This seems ok. Then one possibility is that the Sample Rate of your device is slaved by an external clock, and in this case, WaveLab can’t change it. This should be changeable from the Control Panel of your device.

The clock is set to internal. As I said before I can close WL7, open WL6 and it is fine. I can even change the SR in WL6 without a problem. I must admit I dont quite understand why I can do this as Akoustic Piano is using an ASIO driver at 96K which would mean 2 different sample rates on the one soundcard! but it works. Maybe because AP uses a software return but it still seems strange.

BTW, what settings do you have for the “Input dialog”? (see button “Set input” in Record dialog)

I have got to the bottom of this. In WL6 the MME driver is selected, in WL7 the ASIO driver is selected which is already being used by Akoustic Piano. If I use the MME in WL7 then it works. I always thought that only one audio driver could be used at any time, this appears to be two drivers being used simutaneously at two different sample rates on one soundcard. This frankly I dont understand, if you have a simple explanation Phillipe then I would like to hear it. Thanks.

The Reason is that MME does not try to change the sample rate of the card, instead it does real time resampling. This is why you can playback any sample rate with MME.

And record presumably, I thank you for educating me.