Registering Dorico 4 Pro

I want to know wether my installation of Dorico 4 Pro is registered or not.
How do I go about registering or is it the same as ‘verifying my Download Access Code’.

Hi Julian and welcome!

I suppose if you open the Steinberg Activation Manager (aka SAM), it should tell you whether your computer has a valid license for Dorico 4.

Thanks! I was not too sure of the exact meaning of the phrase ‘register your product’.
It seems I had already registered Dorico Pro 4!

1 Like

Yes, because Dorico 4 uses the new Steinberg Licensing system, simply having the application activated is all that’s required to register it: it is indivisibly associated with your Steinberg ID.

I can also see some misleading information on my Mac. In Steinberg Activation Manager I can see that Dorico 4 Pro is activated. However, in Dorico, in Help menu there is a “Register Now…” entry which makes me think that it’s not registered. If I click on that menu item it takes me to this web page: Then, if I click on “Show eLicenser–based products” it takes me to another page which should show my products, but strangely I can only see “Dorico Pro 3.5 (Not upgradeable)”, activated on the date I bought Dorico 4 Pro. Furthermore, I never had 3.5, I previously had Dorico Pro 3, from which I upgraded from.
I hope these are some bugs and database inconsistencies and hopefully I won’t lose access to the product.
Thanks in advance!

Probably we should remove the Register Now menu item now, since it’s not really necessary since Dorico has switched to Steinberg Licensing. In the new system, as soon as your license is associated with your Steinberg ID, it’s registered. So there’s nothing to worry about: if your product shows up (activated or otherwise) in Steinberg Activation Manager, it’s registered.


Hi! I attempted to update from Dorico 4.1 to 4.3 tonight, and now am having trouble Saving the file I was working on tonight. Is this an activation/registration issue? I do see Dorico 4 under my registered products in the SAM, and used to have no problem saving for the past few months since first upgrading to Dorico 4. There is a work at risk of not getting saved.

What is happening when you try to save your project? Does it give you an error of some kind? If you do File > Save As and save it under a new name, does that work? If you’re trying to save it to a cloud drive or a network location, try saving to your computer’s local hard disk instead. If you’re saving to a subfolder nested very deep in your filesystem, try saving to a location closer to the root of the filesystem. Do any of these steps give a different result?

You should also run Steinberg Activation Manager and see whether or not Dorico shows as being activated or deactivated.

When I try to Save As- both from the menu and from Shift-Apple-S-- what happens is at most just a little scrolling pinwheel, sometimes nothing at all. There is not even an option to choose the location or name. In Steinberg Activation Manager Dorico 4 is showing as an Activated product. The only step that seems to have worked is that I was able to Save As A Template.

If you type Command-Q to quit the application, you should (I hope) be prompted to save your changes: if you click Save at that point, hopefully the file will be saved. Also worth going in the Finder to the location where the project is saved and checking the file modification date shown: does it appear to be updated when you save?

Hi Daniel – I had tried both those suggestions earlier with no luck. It was actually while trying to Quit the application that I first encountered the issue.

The workaround of Saving As A Template seemed to work, then I shut down the computer, and updated to latest OS (12.3.1 from 12.0 earlier). So far the issue hasn’t recurred, Saving seems to be back to normal-- but let me know if there’s some sort of bug reporting I should do with this.