Rehearsal mark delete bar numbers and bar frequency problems


I noticed that the Rehearsal mark will hide bar numbers.

Is there a way to have both the rehearsal and bar number at the same time?

I can’t have bar numbers appears as default even I go to Layout option and
“Save as Default” (in Full Score, Part, and Custom.

Is it a bug?


No, it’s not a bug. You just need to scroll down.

Thank you very much for the rehearsal marks with numbers.

What about I can’t have bar numbers appears at default?

You’re right that it doesn’t seem possible to save this as default (unless at the same time that you change this default you’re also changing at least one other setting). I guess this may be a bug.

Yes, it seems to be a bug.

If I change other things “Save as default” the Apply button will change color but it will not change the fact that bars numbers are not as default.

I can definitely persuade that “Show bar numbers at rehearsal marks” to Save As Default as long as I have either changed another item or Applied first.

I just realized that I can’t save as default Marker with bar numbers neither.

What I’m doing wrong?

I go to Layout option / click on Show bar numbers at rehearsal marks (turn blue)

With Layout type on Full score or Part, I click on Apply.

But next time I open a project Show bar numbers at rehearsal marks is turn off again

Default settings don’t apply to existing projects unless you then Reset to Saved Defaults. Are you doing that?

I didn’t need to reset as default to get the bar numbers and rehearsal marks to appear properly.
Apply and close work fine.

I mean that the options I saved as default are not appearing when I open a new project

In this case, bar numbers are again not appearing and Rehearsal marks still hide bar numbers.

Make sure that when you want to set your defaults, that you have already applied the changes you’ve made. In Layout Options, set your options as you want them, then click Apply, then click Save as Default. You’ll then find that those settings are used by new projects you start.

Thank you very much pianoleo and Daniel,

Very nice! “show bar numbers at every system” and Bar numbers at rehearsal marks are saved as default with new file :smiley:

I think I got confused with the bottom left “Full Score Custom and Part”
and didn’t select the good part in the right side of the Layouts panel,
So it works only in the score probably.

But when I import XML files I still have bar numbers to “None”
but Bar numbers Rehearsal Marks.
(that another reason I got confused)

I attached some screenshots
I could get the bar numbers at every system but had to do it manually,
and can’t save as default, I guess because it already set.

Thank you for reading this.

I’m sorry, cellicello, but I’m not sure exactly what you’re reporting here. Could you try explaining it to me again?

Thank you Daniel for taking time for my case :slight_smile:

I trying to explain that as a beginner I get confused with
the Layout Options Panel “Layout Type” (on the bottom) and Layouts (on the right side of the panel).
That might explain why I couldn’t properly save as default properly “Show Bar numbers at Rehearsal Marks” and “Bar numbers at every system”

Another thing is that when I import XML files from Logic to Dorico.
I don’t get the bars numbers on each system even it set as default now.

Possibly the MusicXML file you’re importing from Logic has some specific instructions that tell Dorico not to show bar numbers. Perhaps you could zip up and attach one of your MusicXML files so we can take a look.

thank you Daniel for taking care of this.

I attached an XML file from Logic and the notation setting panel of Logic.

I’m not an expert in music notation of Logic
XML fom (193 KB)

Indeed, for whatever reason your MusicXML file contains the instruction:


which means that it explicitly encodes that bar numbers shouldn’t appear. (You can read the MusicXML documentation on this here.) I’m afraid I’ve no idea how you would change this in Logic.

Whoah, thank you for taking care of this.
I’ll try to find a way to get bar number with Logic XML file.
Take good care of yourself.