Rehearsal marks overlapping lyrics

Working on a score that has both lyrics and rehearsal marks. Sometimes the rehearsal marks are covering up lyrics, and I’ve not yet found any way of resolving this.

Currently using Dorico Elements 4; is there a way to fix this in Elements? Or if not, is there a way to fix this in the full version of Dorico?

EDIT: Added a screenshot example; there is a lyric word hidden behind the B rehearsal mark.

The problem is you have a chord symbol and rehearsal mark at the same spot. Try nudging the chord symbol over by an 8th or so, and the rehearsal mark will pop back down into place.

Hmmm… It seems that works if I offset all chord symbols from the main chord symbol menu, but if I offset just that one chord symbol, the rehearsal mark doesn’t move.

Also should mention, elsewhere in the same file, there are other similar instances of lyrics + rehearsal marks + chord symbols that are not overlapping. I don’t see any obvious difference – chord symbol on first beat of the new system, rehearsal mark above it, lyrics above that. All spaced nicely vertically. Would like if all instances did that!

If it helps, he’s talking about moving the chord symbol to a slightly later beat position rather than just moving it in Engrave mode. With the latter the rehearsal mark won’t change.

1 Like

Okay, I see. This will work for me in some scenarios, not in others. Thanks for the ideas!

Try this solution too, (cmd+shift+E), your rehearsal marks won’t never collide with chord symbols:


As NorFonts stated above, you can left-align with barline, but then you can also specify a horizontal offset. Here’s what I get by default with no manual positioning when both the chord symbol and rehearsal mark are assigned to beat 1 at the beginning of a system …


… using these settings:

The catch is this won’t work on a grand staff part so you’ll have to manually offset those. (I’ve forgotten the reasoning, but I think Daniel had said this wasn’t actually intended to work this way.)

Perhaps the problem is simply the choice of font for the Chord Symbols?
(a) it looks big (to my untutored eye)
(b) the the style, which subscripts the root makes it take even more vertical space.

The root problem is: At first Dorico thinks this number of lines (systems) will fit on the page, but then it does collision avoidance (moving things only vertically, not horizontally) and the page becomes over-filled. The sad result: collisions after all.

I think the quickest way to fix the obvious collision is just push a line onto the next page. But don’t do this kind of thing if you’re still writing, because you’ll probably have to go over it again later.

BTW, why do you have only one bar (13) on that line? Was it just to illustrate the type of problem?

Indeed. I’d also suggest that you don’t System Break every system. Use Dorico’s Note Spacing value, or the Casting off options in Layout Options.

I’m thinking this Rehearsal Marks Playing Position setting must be a Dorico Pro option? Not seeing it in Dorico Elements?

I will try pushing a system to the next page, thanks for the suggestion.

Yeah, that single bar on a line by itself wasn’t intentional, possibly occurred while fiddling with things trying to fix the obscured lyric text.

I’m not particularly a fan of this slash style, but I definitely don’t like Dorico’s way of spacing and alignment with these.

Here’s what it looks like in Galley:

… and here’s Page with lots of unnecessary white space:

I would love an option to sort of split the difference and center chord symbols that use a slash like this:

1 Like

Sorry, I missed you stated you were on Elements. I don’t think Engraving Options exist in the Elements version.

Isn’t the root cause of the problem Dorico’s inability/unwillingness to recalculate vertical spacing after Engrave Mode edits?
Could someone point me to an explanation or reasoning for this behavior? Obviously I’ve encountered the OP’s case on numerous occasions myself… :wink:


As would I. I personally like the slash style, but chords without altered roots just float too far away by default.

1 Like