Remove gaps in Midi track (instrument track midi data)

Hi,

I recently upgraded to Cubase 6, and although I cant remember ever doing this in Cubase 5, or for that matter, 4… as Ive hardly used any of them properly - I’m sure this must be possible.

I think what I’m after is known as Ripple Editing in Reaper? (a friend told me this, I’ve never used Reaper).

What happened was, I recorded myself playing a piano piece into an instrument track, via Midi. I made a few mistakes along the way, wrong notes, too-long pauses etc. but carried on playing, thinking I could easily edit them out later.

I managed to get rid of the rogue notes easily enough, but the pauses have me stumped.

So I have my track containing the midi data, with say a 1 second gap at 0:35-0:36 that shouldn’t be there. Then another at say 0:58-0:60 and one later at 1:58-1:59

Short of grabbing all the midi events beyond the gaps, and dragging them left a bit, is there not an easy way to just select the gap, and remove it, so everything that was to the right of it is automatically shifted left by the desired amount?

I don’t have access to Range > Delete Time when editing the midi part of the track - the option is disabled, so I can’t move the left/right locators to cover the gap and choose that option.
The option IS, however, available to me if I’m just in the main project window, but when I do that it doesn’t do anything with the midi data at all… the gap is still there.

Am I doing something wrong? Is this because I’m using an Instrument Track, rather than just a simple Midi track? Or is this sort of function only available for audio data?

Thanks.

I don’t know, if this is what you’re looking for:
http://www.youtube.com/watch?v=cbdldKjutsI
Here demonstrated on audio tracks but works on MIDI/Instrument tracks too.

I’m not 100% but Shuffle might do what you want. It’s in the Snap mode drop-down menu.

I think the best way to do this, in the case you describe, is to remain in the Project window, open the In-Place Editor for that MIDI track, select the “gap” in the MIDI data, using the Range tool, then Edit menu>Range>“Delete Time”.

Thank you all for the replies. I’ll give them a go when I get home… probably tomorrow :frowning: