Removing final (pickup) beat from last bar in a choral flow

I’m hoping somebody can tell me how to remove the last beat from the final bar (4/4) in my flow.

I’ve spent an hour trying to learn how to do this very simple task. I’m in 4/4, and each verse starts with a quarter note pickup. I want to remove 1 beat (1 quarter note) from the FINAL bar in the song. But I don’t want to turn it into a 3/4 bar.

I have read and re-read help articles, and have watched videos. I found 2 places in the documentation that give me DIFFERENT ways to do this. Neither works. I have been over them again and again, pretending that I don’t know English, and double-checking myself on every word in the instructions. They still don’t work.

It should be an exceedingly intuitive process, I would think. But it is not, and not even Dorico’s own documentation staff seem to know how to tell somebody how to do it.

$600 is a lot to pay for this kind of frustration when I can get the same frustration for free at Musescore.

These directions won’t remove a single beat. They remove the entire bar:

https://steinberg.help/dorico_pro/v3.5/en/dorico/topics/notation_reference/notation_reference_bars/notation_reference_bars_beats_deleting_system_track_t.html?hl=final%2Cbeat%2Cbar%2Cflow

And these directions won’t remove a BEAT from the measure; they simply delete any NOTES that exist during the beats in question. So, for example, putting the carat at beat one and entering “-1q” into the popover turns a whole note into a dotted quarter, and leaves a quarter rest at the end of the 4-beat bar.:

https://steinberg.help/dorico_pro/v3.5/en/dorico/topics/write_mode/write_mode_notations_input/write_mode_bars_barlines_popover_r.html?hl=final%2Cbeat%2Cbar%2Cend%2Cflow

Select the note that’s on the third beat and type Shift-B, “final.”

Shift-B, -1q should also work, but you need to first select the final quarter rest. Not the downbeat of the measure.

I feel your frustration, but next time don’t spin your wheels for an hour. Ask here and get a (usually) quick solution!

1 Like

I’m really sorry to hear you didn’t get the answers you needed, especially given that you’re right that the docs aren’t accurate on this. I do check the functionality of everything that goes in, so I’m sorry that I appear to have been mistaken when I wrote this. (Anywhere else, i.e. in the middle of bars, this both deletes notes in the selection and “fills in the gap”, whether or not Insert mode is active.)

Dan’s tip to input the final barline first, then remove the excess bar at the end is good - although “-1q” apparently wouldn’t work either in this situation. I think Dorico is reluctant to leave an impartial bar without encouragement from an explicit barline - I’ll double check this with the developers, and improve the documentation for future manuals. Thanks again for bringing it up.

1 Like

Funny enough, I’ve had to do this exact task this morning and had to use trial and error since shift-b -1q would not work as intended. I had to input the final bar manually at the fourth beat and delete the one beat-bar remaining.

I’ve often wondered why Shift-B: trim doesn’t take care of this. I find the Shift-B popover syntax to be a guessing game, because it seems to respond differently given whatever the current status of Insert Mode might be, coupled with whether I’m working in an open time signature. I always get to where I’m trying to go, but it’s maybe after three or four attempts.

Trimming the flow typically only trims to complete bars. Dorico doesn’t have any specific feature to “balance” pick-up bars with the final bar of a flow, so trimming the flow won’t cause this to happen either. But adding a final barline is normally sufficient, without need of removing the excess sub-bar-length bar at the end, as normally there isn’t one.

I’ve just spent a little bit too much time struggling with this exact issue. Thankfully I found this thread :slight_smile: (The ‘Shift-B ‘final’’ trick did it to me.) But I have a suggestion about the documentation (Bars and barlines popover ; this is what comes out when I google ‘dorico bars and barlines popover help’; I don’t know if there’s an updated version):

  1. I had no idea after reading the help page that ‘final’ would insert a final barline and trim the rest of the flow. I assumed I’d have to select a barline first.

  2. All the commands I tried which are supposed to ‘delete a beat’ etc. do not delete the beat (or whatever other duration I set): they delete the pitches and substitute them with rests. (So the duration of the bar does not change.) Is this intentional?

[Dorico Pro 3.5.11]

I don’t know what I’m doing wrong but I can’t get anything to work. I am able to insert a barline using the methods suggested above but when I delete the extra bar I lose my Final Barline and nothing I do will put it back. Daniel says that “Dorico doesn’t have any specific feature to “balance” pick-up bars with the final bar of a flow” but I reckon it should.

I’ve experienced this on occasion, and have worked around it eventually. Can you post the project here and let one of us try our hand at it?

This is not a serious project - just something I was using to test a few things out. But the final bar should have 2 beats. I got rid of the third beat but now can’t make the final bar line anything other than a normal barline.
The Broken Down Squatter.dorico (666.0 KB)

Select final barline and delete it
Select quarter rest that appears
Type <shift>B
Type final into popover

1 Like

Fantastic . . . that seems to work every time! :slight_smile:

Thanks so much Craig!

Wayne

While I have your attention Craig, would you mind telling me what the easiest/proper way is for me to get get rid of the overlapping issues in this score?
Overlaps

I am very new to Dorico and am trying to find out these things for myself using the documentation but I’m not finding it easy (I am switching over from Sibelius, by the way).

Wayne

Go to Engrave Mode and turn on the Note Spacing tool. You’ll see all the systems are overfull (>100%, shown in red). Having systems overfull causes the poor spacing and overlaps.

Try adjusting the note spacing, found in Layout Options—Note Spacing as well as the various lyric spacing options found in Engraving Options—Lyrics. Combining that with changes to the casting off will get you much closer to a finished result, which you can then manually adjust with the Note Spacing tool in Engrave Mode.

Thanks for your help Alexander.

I found reducing the Rastral size (Layout Options/Page Setup/Space Size) from Size 4 (6.5mm) to Size 5 (6.0mm) solved my problem. I realise that I could also have left the Rastral size where it was and just made a couple of manual adjustments with the Note Spacing tool if I’d really wanted to keep the music larger.

Cheers . . .

Wayne

The first thing I always try when I see partially overlapping or jammed-together lyrics is to double-click the first syllable (which brings up the Lyric Tool and box) and press Space or Hyphen as appropriate to move to the next syllable. Sometimes this in itself repositions the offending syllables, although this method is less likely to work in overfilled systems.

Changing the rastral size is the better option. You’ve packed the music pretty tight via system breaks. Nudging things in Engrave mode should be a last resort.

You can also try decreasing the default note spacing, which will tell the algorithm to recalculate which might make for nicer results too.

Thanks for all of your suggestions . . . I have learnt a lot from them.

I have to say that as a new convert to Dorico, I am very impressed with the amount of friendly support that seems to be floating around the forums. People willing to give of their time to help their fellow notators.

It is most encouraging to know that there is somewhere for me to go if I need some help! :slight_smile:

Wayne