Removing noise from a track

Recording direct guitar (heavily distorted) using VST plugins is very noisely and the noise isvery noticable in choppy parts and parts the ring out.

When I used Red Roaster (v5.5) way back when, it has a function that allowed you to sample a portion of wav file, then remove that sampled noise from an wav file.
So, let’s say you had a hum all the way through a guitar track, you could sample any place where the hum was isolated, then remove the ‘noise’ from the entire track by basiclaly creating a filter form the sampled noise. Is there a plug in out there that does something similiar?


I’m surprised you haven’t just run the sampled portion through Audacity.

The best method of removal would typically be to apply a noise gate to the audio, but that will only remove noise in the quiet parts of the audio during recording. You’re suggesting the option of noise removal in loud parts as well… for that I’d use a plugin that does noise removal. I’d try Wavelab or Audacity to do those things because I’ve heard both have fairly good tools for editing that in an offline sense. Otherwise, I’d just re-record the source material better…

Thanks for the input.
I’d rather not have to go to an outside program. I was hoping what I described in a program I used 10+ years ago would be available in Cubase.
Noise gates suck and it sounds like you’re using a noise gate. I can go through an manually edit out quiet parts the track and get a better result. But, its the fast choppy parts that are hard to edit.

Otherwise, I’d just re-record the source material better…

My guitar is going direct into my MR816. Clean parts fine and quiet. It’s VST guitar plug-ins that are creating all the noise. To get a sound that’s ‘metal’, you get a bunch of noise. I tried using the VST Amp Rack and it was noiser than what I’m currently using.

Most of the noise is actually being generated at the guitar, using extreme amounts of gain as a distorted guitar plugin does, will cause noise. Try unplugging the guitar at the interface and see how less the noise is now!

There are things that can help, the first thing is to get the noise pickup down to a minimum. Single coil pickups are far more noisy than humbuckers (there’s a clue in the name) any stray electrical noise from various sources, CRT’s, Dimmers, or even sitting on a amp (being close to the power transformer) and just general elecromagnetic noise flying about your room will get picked up and amplified. As an experiment, plug in your guitar select a sound where the noise is apparent and rotate through 180deg and note how the noise changes. Sometimes it may even be possible to find a position of minimal noise. The other thing is the use of a noise gate at the guitar before the interface, or if not available maybe in the input of the guitar sim, this is far less obtrusive that trying to gate the result after the amp. The final thing is of course playing technique, minimising the thump or twang on muted chords and notes. Prevention is better than cure, or at worst makes the cure a lot easier.

Aha, so that’s the problem, I don’t think I got it the first time (the amount of sleep I’ve lost lately is considerable).

I actually had this problem with Guitar Rig for a while. Unfortunately, the only ‘real’ way to avoid it is a noise gate, as I’ve found most forums I researched the problem with said so. I know there’s one built in on Guitar Rig 5, so there’s probably one built in on the amp simulator you have for just that purpose.

If the noise is HF static you might be able to put a low pass on the guitar before you push it into the amp VST. Adjust the cutoff to 16KHz or lower and see what happens. If the noise happens to be any lower, you could try a notch filter and pinpoint the exact trouble frequency of the noise and remove it all together (though there’d be some lost quality there).

I’d try sweeping with an EQ first to really get an idea of how much you’d want to remove, using a narrow EQ band so not to risk tampering with the source material too much; but, if the clip is going through an amp, well… that’s a lot of tampering anyway so it probably wouldn’t matter as much.

A lot of noise removal plugins use an EQ or a filter to get rid of specific frequencies that are trouble spots, or rebalance the entire clip so that the noise is lessened. I know Cubase has a tool for creating silence in between clips, but for the noise within clips you’ll probably have to process it old skool.

Decreasing the input volume into the amp plugin might solve the problem too, given that higher volumes will expose the noisefloor of the recording more.

The ‘commercial’ option would be running the guitar sound through something like Izotope RX. Honestly, I wouldn’t do it, but it could be something to look into.

Could be the guitar too (like the poster above said). If you’re running it through something like an amp, you’ll want a clean power source so a power conditioner would be the way to go. As the poster above said, other electronics will generate noise. I’d also check your cable to make sure it’s well shielded. Also make sure the interface isn’t producing the infamous ground hum…

Sorry I can’t be of much more help (just throwing stuff out there), but it’s been a while since I’ve done a real recording.
Hope I can be of more help, but I imagine there are others here that know better :slight_smile:


I had a similar problem where the first bars of my guitar solo recorded static that sounded like crackling but after a few bars the rest of the track was very clean. I clipped out the first few bars, re-recorded it on another track and cut/pasted it back to the original track. However, there was still the crackling for the first 1 second. After trying several things including recording the one guitar part in a new file with no other tracks and inserting it back as a wav (it didn’t crackle in the new Cubase file, but crackled for 1 second after inserting it into my original), I wrote down all my insert settings for each track, then I deleted each insert for each track. I rerecorded the first bars of my guitar solo, glued it to the original and then re-added my inserts at the same time using my hard copy track list. I had been recording one track, and adding inserts/plug ins to it before going on to the next track. I repeated this process until I had 8 or more tracks. In the future, I will find the insert as I go, but remove it after I find what I like before moving on to my next tracks. When I get to the end of the song I will add all my inserts at one time, and before mixing. It may just be my computer, but this fixed the problem for me. There is no noise and no bogging down on playbacks. I hope this helps somebody. I spent about three hours figuring this out.