Removing triplet rests

I’ve run into a problem that seems connected to a similar question that was asked before (How can I change “normal” notes into triplets? Answer: You can’t, yet). But whereas that solution only requires rewriting the three affected notes, I’m stuck finding my way out of this one.

Steps to reproduce:

  1. Double-click at the fourth beat of a 4/4 bar. What I’d like to do is insert eighth note triplets leading into the next bar. I therefore click the triplets button.
  2. Oops, double-clicking had set quarter notes, so instead of a single eighth rest triplet, I now have two.
  3. Enter the three eighth notes anyway.
  4. Now try to get rid of the second triplet I don’t want. How? I can’t change it back into “normal”, I can’t seem to delete it either. The triplet rests stay there forever.

Undo sometimes crashes, sometimes doesn’t do anything, sometimes leaves the first bar with three normal eighth rests at the end (so it contains 9 eighth notes), depending on what I’ve tried doing in the meantime.

Is there anything else I can do? (Besides remembering to press the eighth note button before pressing the triplet button?)

you did actually create a triplet which allows you to write the equivalent of 3 quarter notes, but has a duration of 2 quarter notes. Because of the current position, that happens to be notated as two triplets next to each other. If you now enter 3 eighth notes below it, there will still be 3 rests, as you noticed.

We don’t currently have any tools to change the duration of an existing tuplet at all, so you will have to delete the tuplet itself, then re-enter it with the desired duration clicked beforehand.

Note, if you delete the tuplet, but don’t have the notes themselves selected, then those notes will unscale and potentially overwrite music following that tuplet. In your case, that’ll only overwrite some of the rests you don’t want anyway. If you do that deletion in insert mode, then those rests will stay and music following will move out a bit.

You also mentioned undo not working, or crashes. This certainly shouldn’t happen, and it would be great if you could provide a (simple?) example that demonstrates both of those unexpected failure cases.

Thanks - the crash occurred after I had tried a lot of different things to remove those triplets, and I haven’t been able to reproduce that yet. Same thing for Undo getting stuck. I’ll post it if I can find a way to reproduce that.

To remove an unwanted triplet, I Select the triplet and press Delete. It replaces the triplet with a rest, and I can go back and insert the note(s) I want.