Render Bug for gapless albums. Inserting silence in rendered audio files

I was rendering a gapless album today where most of the songs flow over into each other with no pause between songs. All songs are the same format (24bit-48khz).

I kept noticing a dropout/silence that was inserted in the audio directly after where I’d placed the Splice marker on the rendered audio. This happens on all songs with a plugin inserted on Clip fx, and that have gapless transitions between songs. On playback before rendering everything sounds perfect. This is only happening on rendering!

After a lot of investigation I’ve realised that when I have a plugin directly on a clip, and have gapless songs (with splice markers), the render will have silence that amounts to the same number reported on a plugin as its latency in the Clip fx section. Say for example if I insert a Weiss DeEss plugin, it says 55ms after the plugin name in the Clip fx. The rendered audio will then have a 55ms of silence inserted just after the cd marker.

Once I remove these plugins from the clip section it renders perfectly, with no dropout/silence.

I’ve tried this with several different plugins (DMG Essence, Weiss DeEsser and Fabfilter Pro-L). It gives the same result with all these different plugins brands. The silence inserted in the rendered audio just changes length according to the latency reported for that particular plugin (40ms, 55ms, 60ms etc).

This makes WL10 unusable for rendering gapless albums for me! I need to be able to use a single plugin directly on a clip and have it render perfectly. This was not a problem in WL9.

I have not noticed this on songs with normal gaps between them. Only today on this gapless album. I’ve done this 1000 times in WL9 without any issues. I always make sure to quantize the cd markers to the closest cd frame before rendering. It´s not that! I believe it has to do with plug-in latency somehow.

I’ve tried both VST2 and VST3 versions of these plugins. Problem stays the same. Even tried it on two different Mac machines. One desktop machine running WL10 on High Sierra, and the other a MacBook Air with Catalina. Exactly the same results on both machines.

I’ve tried all combinations of plugin placements (Clip, Track, Montage Out, Master). The only place inserting a plugin gives this issue in the rendered audio is in the Clip section.

:astonished:. :open_mouth:

I did a quick test but could not reproduce.
What kind of rendering do you do? After rendering, you should get an audio file, but your picture “After Rendering” shows a montage.

Thanks for the reply!

I render the audio from a montage through the resampler (set to 44k) in the master section, then a Mbit+ dither (set to 24bit) after that.

The images show the original material in the montage before rendering, and then the rendered audio file imported into a new montage.

I’ve tried these things:

  1. Render with no plugins at all in the montage = perfect rendered audio

  2. Render with just 24bit dither in the master section = perfect rendered audio

  3. Render with 44k resampler and 24bit dither in the master section = perfect rendered audio

  4. Render with a limiter plugin inserted on the track containing the audio in the montage, 24bit dither and 44k resampler in the master section = perfect rendered audio

  5. Render with a plugin in the montage master output = perfect rendered audio

  6. Render with several different plugins / only one inserted on the clip section at a time = produces the silence amount reported by the plugin (i.e 55ms) directly after where I put the splice marker in the original montage.

You have to try this with two songs overlapping each other. No gaps!

Heres a picture of the original mix (before mastering), and the rendered audio imported into a new montage. You can clearly see the silence inserted right after where I have my Splice marker in the montage I render from:

It seems like the silence inserted after the splice marker perfectly represents the latency number reported by the plugin in the Clip section. If I use a DMG Essence it can for example read 31ms in the clip section for the latency. Then I get a 31ms silence on the render audio after the Splice marker. Every single time! Regardless of which plugin I use. As long as it’s placed in the clip section it goes wrong. Remove these plugins in the clip section. Problem gone! It´s like the transition from one song (containing a plugin on the clip) to a new song (containing a plugin on the clip) does not go well when I have songs overlapping each other.

I don’t think problems like this are totally unique to WaveLab.

For this reason, I always do a full render of the montage as one long floating point file at the same sample rate, and have WaveLab create a new montage from the resulting file so all the info is carried over (markers, CD-Text, etc.).

Then I can add a dither to 24-bit and safely render a WAV of each track, or SRC that full render down to 44.1k, use Custom Montage Duplicate, and have a full identical montage at 44.1k to render WAVs of each track from…or DDP, etc.

Render what? In the render options, there are many options, like render whole, selection, selected clips, etc…
I need to know your render options.


I’m rendering “All Regions - CD Tracks” (with “include pause after track” option on). I have one start marker before the first song, then only splice markers and an end marker after the last song. I end up with 10 rendered audio files.

Original File format: 24bit-48k WAV

Output Format: 24bit-44k WAV (SRC’d and dithered through the master section).

Rendering 10 audio files, with plugins on 4 of the files in the clip section and a DMG Limitless limiter on the track.

Songs that do not overlap are fine. Only the ones that have audio overlapping (one song cross faded into the next) have these problems.

Tried thrashing all preferences. Same thing happening. Silence inserted on the rendered files.

I’m used to do this in WL 9.5 all the time with zero problems. Will reinstall WL 9.5 and try to render the same files there. I’ll let you know how that goes

Just tried rendering in the exact same manner in WL 9.5. This produces perfect results. Opening the same montage and rendering in the same way in WL10 produces rendered audio files with silence inserted!

So this is very much a WL10 specific thing! WL 9.5 renders these files, with the same plugin setup in the montage perfectly! Something is not right with WL10!

You can see the rendered files from WL9 and WL10 compared to each other in this image. The same exact montage rendered in WL9 are the green files. The files rendered in WL10 are the purple ones. You can clearly see the difference here! The purple files have the inserted silence.

These are the exact same montages, with the exact same plugins rendered from both WL9 and WL10. I created a new montage today in WL9, rendered the files, openened the montage in WL10 and rendered the same files there. As I said before I´m rendering using the option “All Regions - CD Tracks”

So basically WL9.50 renders perfecly, but WL10 does NOT! :confused: I´ve never had these rendering issues in WL9. Something is fishy with plugin / latency / rendering gapless in WL10.

One more update on this. Tried rendering the WHOLE MONTAGE in WL10. That gives a perfect result. When I then try to render All regions - CD Tracks I get the silence again.

See this image comparing the two results. The top file is the whole montage rendered as one long file in WL10. The bottom file is rendered with “All regions - CD tracks” in WL10.

So something happens in WL 10 (not WL 9.5) when rendering with the All regions - CD tracks option. What is this?


Thanks for the info, I could reproduce. This must be fixed for 10.0.10.


Do you have a workaround for this? Besides rendering the whole montage, importing into a copy of the org montage etc, then rendering separate files.


I’m afraid I’m experiencing a very similar, if not the same bug.

When I render a single “selected cd track”, WaveLab 10.0.40 inserts silence at the beginning of the generated audio file.

Also for me, bypassing the clip plugins, or rendering a “group of cd tracks”, the problem is solved (on the other hand, in the name of the generated files the track number is wrong).

But please note that in my audio mantage there are 2 seconds of silence between one track and another: that is, it is not a gapless album.

Do you have any advice?


You probably use a plugin that does not declare properly its latency to WaveLab. Find this plugin.

Trying to render accurately gapless WAV files per track with anything other than zero to light plugin processing is a recipe for a problem. Not just with WaveLab, but I’ve heard of cases in nearly every other DAW too.

Do a full render of the entire project in one pass to lock in all the processing first, then have WaveLab create a new montage from the resulting render which can automatically transfer over the markers/data, and then render track by track which you can do safely without issue.

I can get away with Goodhertz Good Dither running live and rendering track by track to produce gapless WAVs but anything else is an invitation for something to go wrong.

It’s also an issue for non-gapless projects, it’s just that yo can’t hear it as easily :slight_smile:

Good morning

thank you for your suggestion. In fact, the problem does not arise when removing the Classic Clipper plugin, from IK-Multimedia.

If I understand correctly,the problem is in the plugin itsleft: that should I notify the manufacturer? Or I can change some configuration within wavelab? For example manually set the plugin delay, if possible