Render by Regions (CD Markers) does not create tracks cut on CD sector boundaries

Here’s a little puzzle for y’all, and thanks for looking…

I have a monolithic 16/44.1 .wav file in a montage tracked out like this:

I use Functions > Move Multiple Markers to quantize these markers to CD frames:


Then I render the whole montage to a new .wav file. Last step, I use Process > Auto Split and split the renedered file up by CD markers into separate tracks. The result is a series of named .wav files cut on CD track boundaries. I’ve done this a zillion times, no problem.

Today, I had a montage that didn’t need any effects or processing, so there was no need to render it to a new .wav file. Therefore, I rendered the montage into separate .wav files by selecting All Marked Regions, using the region names as file names, and the CD markers as the region boundaries. This generates the same series of files as Process > Autosplit.

None of the tracks were cut on CD boundaries. That’s unexpected and it seems strange to me because the region boundaries are located at CD track frames. What criteria is Wavelab using to decide the length of the rendered files if not the location of the region boundaries?

Am I doing something wrong? Or is Wavelab? Thanks.

I think I have solved the puzzle. I don’t think you want to use the Move Multiple Markers option if you only want to quantize markers with no other movement of markers first.

My understanding of how the Move Multiple Markers window works is that the quantize option is only applied IF you are also moving markers. So in other words…if you were to move the markers by 1 second and THEN WaveLab quantize them after the move. I think that since you’ve got it set to 0 seconds, that it’s also not quantizing markers. This is a somewhat new feature to WaveLab and maybe this scenario wasn’t thought out.

I just tested myself and put markers in random un-quantized locations and then ran the Move Multiple Markers option with your exact settings and the markers did not quantize. I can tell because the montage doesn’t indicate a change and require me to save it to get rid of the red dot.

Instead, if you JUST want to quantize markers and nothing else, try using the setting shown here in the CD Wizard where everything is deselected except for Quantize Markers To Nearest CD Frame.

See if quantizing that way makes a difference:

You are correct. The CD Wizard way results in properly quantized markers.

I used to do it this way until PG1 suggested using the Move Marker’s method. I think that it used to work the same both methods. There’s a discussion about it here: Quantize to CD Frame Outside Montage, or Time Stretch within a Montage (but not "to cursor")? - #6 by mgoldey

Thanks for the quick reply!

No problem. I’m always in the habit of using the CD Wizard for quantizing or re-quantizing moved markers.

I only use the option in the Move Multiple Markers window if I am actively trying to move markers so that aside from moving the markers by a certain amount of time, the markers also get quantized and I don’t have to use the CD Wizard separately to quantize them again. In theory, it saves a step.

I’m not sure if it used to work to Quantize Only using the Move Multiple Markers if set to 0s and a bug was introduced at some point, or if it should be made more clear that in the Move Multiple Markers window, quantization only happen if you are truly moving the markers by at least one millisecond first.

PG’s comments in the thread I linked above suggests that both methods should work the same way, and that Markers > Move Markers does not (or should not) require also moving all of the markers by some fixed amount in order to move the markers to the CD frame.

My experience using this feature has been that clicking OK using the settings on the Move Multiple Markers screen I pasted above does in fact move the markers to CD frames. For sure in WL10 it did. I have noticed that, since upgrading toe 11.0.30, certainly, but maybe before then, I have not had the problem of the final track end marker being pushed past the end of the audio (which causes glitches when rendering to tracks, so I notice it for sure). :thinking:

Interesting. I no longer have WaveLab 10 installed to test this out on but it looks like the answer moving forward is to use the CD Wizard to Quantize Only before rendering. Unless this was a recent bug that started in 11.0.30 that can be fixed.

I once asked for a direct command in the Markers Tab to quantize makers but it never happened. I think that’d be the most straightforward solution and perhaps in the Move Multiple Markers box, the Quantize option should be greyed out until the markers are also set to move so it doesn’t lead to any confusion like this.

Also, after reading your threads more, it looks like you might be doing this in the Audio Editor, not the Audio Montage.

I did a quick test and using the Move Multiple Markers option in the Audio Editor with your settings (0s, Quantize to CD Frames) it does seem to move the markers. What’s strange is that it doesn’t seem to do that when the same settings are used in an Audio Montage.

I guess I’m just used to rendering from an Audio Montage so I can use a dither in the Montage Output section and so some metadata can be incorporated too so I didn’t realize you were doing the final render from the Audio Editor.

The plot thickens.

OK, after reading your thread again, it looks like when you found the issue, you were doing it from an Audio Montage but normally do it in the Audio Editor.

I think we discovered that there is a difference in behavior between the Move Multiple Markers box in the Audio Editor vs. Audio Montage when the markers are set to move 0s.

When 0s is chosen, the Audio Editor will still quantize, but the Audio Montage will not quantize unless other movement is also requested first.

You’re about 5 minutes ahead of me :smiley:

Move Multiple Markers works in the Audio Editor but not a Montage

Here’s a before and after in the Audio Editor of a rendered montage, using Move Multiple Markers:




Also, in WL 10, this seems to work the same way.

As a further point, can you see how marker 6 does not seem to have moved? Yet, when rendering within the audio editor – in this case, to go from 24/96 to 16/44 - the last marker disappears from the rendered file, which borks the preceding track #5, as follows:


This happens because the CD track end marker has been pushed to the right, outside the audio itself.


Although it doesn’t really matter for my purposes whether the last track ends on a CD frame, maybe it would be better if WL padded the extra samples with zeros and extended the audio to the new marker location?

(For my purposes, I can simply stop moving the CD track end marker and the problem of the last track vanishing will go away)

Well, there is a lot going on in this. thread but I think it basically uncovered a bug that I’m hoping @PG1 can fix and it’s that in the Audio Montage, the Quantize option in the Move Multiple Markers box simply doesn’t seem to work.

I just told it to move markers backwards by 200ms and quantize to CD frames.

However, when I ran the CD Wizard using ONLY Quantize Markers, the markers move again to what appears to be a quantized time.

The the Move Multiple Markers box, it seems that the quantize to CD frames option can’t be trusted…at least in the Audio Montage. An unfortunate bug to discover.

Or maybe Move Multiple Markers is just picking different CD frames to than the CD Wizard does?

It does quantize to a frame in the Audio Editor. I always confirm the final product with an external program. And this feature has worked, generally, going back to WL6 when “quantize to CD frame” was an option in the preferences dialog.