Render in Place, 15 audio track blank

when I use render in place on a midi track assigned to a multiout instrument it creates as many audio tracks as there are physical outputs of the instrument. for example, I want to render a midi track assigned to halionsonic, and I only have one midi track in the project. when I launch “render in Place” it automatically creates, in addition to the audio track relating to the selected midi, another 15 empty tracks. Where am I doing wrong?

Hi,

You are not wrong. This is by design, Cubase always renders all outputs available, because Cubase doesn’t know, which MIDI Track is connected to which Output internally in the VSTi.

Spero venga migliorato, ha poco senso calcolare inutilmente delle tracce vuote

English?
You didn’t understand what @Martin.Jirsak was saying… it is necessary to render all tracks, because Cubase can’t see inside the plugin on wich tracks it is sending any audio…
You should disable not needed outputs instead… This is a “per instance setting”

I understand, thanks

I believe however that the render in place should only work for the selected part. I understand this is difficult to implement, but this should be “normal” behavior. otherwise what’s the point of selecting something to render it in place?

That’s how it works… don’t understand your problem

the “problem” is only a concept. if I select something that I want to render I would like the process to only concern what I have selected. it works like this, ok !!

Hi,

As we explained, there are 2 possible solutions:

  • Cubase renders only the very 1st output. If you would route the signal to other Audio Return of the Instrument, you would get silent.
  • Cubase renders all enabled outputs, so you always get your rendered signal, plus some silent channels.

In Steinberg, they decided for the 2nd way, which seems to be correct to me.

Again, Cubase doesn’t know the internal routing in the plug-in.

perfect! thanks again for the explanation.