Render in Place "Disable/Remove Source Tracks" Missing

As far as I know when working with MIDI events the only way of adding fades (unless automating CC# 7 or something similar) is rendering the MIDI events to audio (right?). In my project with roughly 16 instrument tracks (MIDI) I firstly arranged everything and when finished wanted to render all the MIDI events to new audio tracks in order to do the mixing. I ended up having to manually disable/remove all the instrument tracks after rendering, which was kind of tedious.

In my Render Settings [Cubase Pro 10.5] I cannot choose “Hide Source Tracks” or “Remove Source Tracks”, neither “Disable Source Tracks”. The only two options I have listed are “Keep Source Events Unchanged” and “Mute Source Events”.
Where are all the other options which are listed in the link down below?
https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/rendering_to_audio/rendering_to_audio_render_tracks_r.html


I hope someone is able to point me in the right direction of finding any working solution to this problem.

Not at my DAW right now so can’t check directly but could this be because you’re rendering events rather than tracks?
To render tracks (and hence get the options you want) you must first make sure no events are selected.

Yes, this was exactly the problem! I was assuming I would have to select everything within a track, but actually it makes more sense the way it is programmed. Thanks a lot for finding my error!
Is my procedure in general correct though? The only problem I could end up with is while already in the process of mixing changing my mind about some MIDI parts which by then have already become uneditable concerning their pitch/velocity values. This has not yet happened to me, but I wonder what I should do in that particular case.

Glad it helped, I think I’ve stumbled over this problem myself in the past which is why I had a vague inkling.

You can always go back and re-enable MIDI tracks if you find you want to change something come mixing. It is a bit of a faff which is one of the reasons I tend not to render MIDI tracks unless I need to.

If you’re just doing it for fades can’t you just automate the track fader? I may be misunderstanding what you’re trying to do exactly…

Yes, you are right I could just automate the track fader. Initially I thought it might be easier to just render the MIDI events and then quickly use the white arrows in the top left & right corners, instead of having to open each automation line manually. However, not being able to edit the data anymore is generally speaking a drawback so I will further look into automation tips & tricks in order to get faster at it.

If you just select the events it wont show Disable or Delete features. You need to select the tracks and events in order to view all features of Source track settings.

Good Luck,
Manoj