Render In Place - Events Clipping Alert

Hey,

To test out the new Render In Place (RIP), I bounced out my Instrument Track: Kontakt running Cherry Bass instrument. The clips were 8-16 Bar segments. I chose to render as separate events.

All is fine, but when resulting audio track is solo’ed, many of the starts of the events have pops–as you’d expect when you’ve butted-up two clips whose waveforms don’t align relative to zero-crossing.

I guess this means that the renderer restarts the playback engine for each MIDI clip that it’s rendering. Meaning we have to be very careful with this feature.

Adding micro fade -ins and-outs solved this, but it’s a significant amount of work.

Perhaps an option to tell RIP tocreate one, big audio file, but slice the events after, would solve this?

I noticed that if I glue the clips before render, the rendering is much faster and you avoid the clicks.

Right, but if you glue them they will become one event, non?

Then what I’m talking about (making separate audio events from separate MIDI clips) wouldn’t apply.

Yes and
No.
Have you tried adding a tail, that would give you something to x-fade.

I guess we are going to find out different ways to work and adapt to the new and welcome features. If you find a good practice, I am all ears.

Yeah, the tail would help, but again, there’s still the work to be done after bouncing. (Love that tail feature, BTW Steinberg!)

Anyway, I had rendered with that method just to test. Normally I would’ve made one big clip. We’ll just have to keep this in mind, moving forward… Perhaps I’ll make a feature request…

I thought I heard somewhere that micro fade -ins and-outs (Auto-Fades) are now on by default globally for all tracks, is it possible you’ve turned them off generally? (I think I heard this, i.e. that they are on by default in one of the new Videos for C8). Maybe I’m barking up the wrong tree here.

Maybe! I’ll check. I’ve turned off any auto-fade settings before, 'cos a) I like to be in charge of such things; and b) 'cos every little fade adds to CPU

In this case, I might turn it back on.

Can you link that vid, BriHar?

Not in a position to ATM but I think it might have been either the Render in Place or Multiband plugin vid on the Products -Cubase page http://www.steinberg.net/en/products/cubase/start.html

Hi,

I reproduced a bug that may have caused the problem discussed here.
I have sent it to steinberg support.

Render In Place seems to ignore muted events (comping tracks) that are overlayed by shorter, aktive events.
You can reproduced it by:

  • take a loop
  • copy it to a second comping subtrack
  • cut it (e.g. alt+scissor every 16th)
  • make the cutted events shorter (e.g. edit length + add fades)
  • mute the whole event on comping track 1
  • select all events of the track (the whole track including every subtrack)
  • render in place
  • result contains the muted events with glitches and clicks

One of the main reasons to use render in place is, that i speeds up working, if you have to bounce a lot.
If you can not trust the result, you have to listen carefully through every rendered piece.
This takes longer than using the old features like freeze or audio export.
So i insisted on a bug fix, since this is important for the trust in “render in place”.

Best regards - YoH

So this still seems to be occurring - just noticed this recently in a bit of rendered audio I was testing. Was driving me crazy for days in trying to isolate what the heck was going on until I did some testing and then came across this post.

So wondering if anyone has found a workaround that doesn’t involve adding millisecond fades to every clip?

This maybe an irrelevant thought, but do you have zero Xover switched on?
Zero X over.jpg