Render in place explaination

Hello, I’m glad to be here.

I used Element for the last year and now purchased Pro for the “Render in place” option for CPU efficiency.

Anyways, I don’t understand why my recording doubles when I render, like this:

P.S. What’s that white color that my recording changes to?

1 Like

Because it’s not destructive editing?
If you don’t need the previous track then you delete it. Then go if you want to delete the actual .wav file you go to the audio Pool, ctrl-P for me, then click ‘remove unused media’ → to trash, then click ‘empty trash’ with delete option. That will totally delete the old files if you don’t want them anymore.
The white means it is muted.

It’s rendered your track and muted (“white”) the audio event from the source track. Check out the options you have to determine what happens to your source (original) track.

You have a mono file on a stereo channel. So when you render, it becomes stereo because of the channel configuration.

1 Like

First, thank everyone, you were helpful.

I found out all this time I acctualy duplicated mono tracks by setting them on stereo.

Now I pay attention to to set the mono tracks to mono, but I still see two wave lines when I render.

Is it because the main Stereo Output?

My conecern is that it duplicate the track again.

In Render Settings Window make sure Channel Settings is selected so it will render in mono.
It is not duplicating but simply making it stereo. No harm done actually. You can check that they are the same level and everything.

You also need to disable or delete the original track to save CPU.
Alternatively you can just freeze the track to save CPU instead of rendering but than you can not edit it unless you unfreeze it again.