Render-In-Place help please

Hi -

Last night I tried RIP for one of the first times. Unfortunately, rather than simply a rendering of the single selected MIDI part, I got a mixdown of the entire project each time I tried it.

The only way I could get just the single selected MIDI part rendered was to manually mute all the other tracks before applying RIP. Is that what is normally required? Looking at a few Youtubes I see that wasn’t necessary … but I did notice in each YouTube there were no mutes/solos applied to any tracks before applying RIP. (I’ve got lots of muted/soloed tracks).

So … do I need to make sure there aren’t any soloed tracks other than the one that contains the selected MIDI part I want to render? That’s kind of a hassle, and I didn’t understand that was necessary by reading the .pdf rtfm, but sometimes I think I may have cortical blindness where that manual is concerned!

Thanks for any help!

Hi,

By “entire project” so you mean all Audio Return Channels of the relevant Instrument Track? This is how it’s specified.

Thank you, Martin, sorry for the ambiguity.

By “entire project” - I meant not just the VSTi piano I was wondering, but also the vocals, drums, bass, etc. that were in the project got rendered as well (!).

To make only the piano get rendered, I had to mute all the other tracks manually before RIP’ng.

Does that help at all in terms of bringing any suggestions to mind?

Thank you again for your reply!

Not at my Daw right now but…

There are some options that will auto mute the other tracks and for some other stuff. I think it is right under the rip option when accessed through the menu.

Sorry I got old dude CRS and can’t be more specific at this time.

Regards. :sunglasses:

Gee, now back at my DAW I checked this out and, in accordance with my CRS syndrome, the reply I posted while not at my DAW was totally off the mark. The only mute options in the settings menu I see are for post processing of the original track that was RIP’d. I tried a bunch of combinations in the setting and with different tracks muted and solo’d. They all result with all tracks being auto muted during the RIP process except for the ones I highlighted to be RIP’d.

So… sorry I wasn’t able to assist. :frowning:

The man “Martin” will, I hope. :wink:

Regards :sunglasses:

Did you just select only the audio event you are trying to render?

Thanks Martin, Prock, and mbira!

After some more troubleshooting, including Safe Mode preference trashing, here’s what I see:

  1. If there are no red “S” solo buttons pressed on any of my tracks, the RIP works just like all the vids. This includes the temporary muting of all the other tracks while RIP’ing is going on; then when rendering is finished - it is successful, and the temporary mutes are released.

  2. However, if some tracks have a red “S” (they are solo’d) before doing RIP, it does not work at all like that. Instead:
    – There is no temporary muting of any tracks when RIP’ng is taking place.
    – The rendered audio includes the one ( :slight_smile: ) MIDI track that was highlighted, AND all the MIDI tracks that were connected to the same VSTi!

Interestingly, I couldn’t reproduce yesterday’s behavior where every single track in the project wound up on the RIP’d audio track, even though only one MIDI track was selected.




************* If someone has a minute or two, can you please do a quick test … solo (red “S”) a few of the other tracks in a random fashion, have one other unmuted MIDI track connected to the same VSTi as the track you want to RIP, then select the one other MIDI track to RIP.

  1. Does the rendered audio include music from the non-selected MIDI track that is attached to the same VSTi?
  2. Do you see the “auto muting” of all the other tracks when RIP is taking place (like in the vid, and like happens if none of the tracks are red “S” solo’d before starting RIP)?

Do I have to copy the project to a dummy project, un-solo all my tracks, run RIP, then transfer the audio to my real project to use this function?


Thanks for any help, I wonder if this is too weird to figure out without re-installing Cubase or something :frowning:

Hi,

What is your Render settings? Do you render just the Track or the whole path? If you render the whole path, the Output buy is rendered in fact. If you solo some tracks manually, they are probably not muted.

Sorry, I’m out of Studio for a week now, cannot test.

Thanks, Martin. I just render the track, top option, not the whole path.

I think the problem is probably that I have many tracks solo’d (red “S”) and muted (yellow “m”) …?

Dumb question - does just about everyone else NOT have solo’d and muted tracks in their projects??

And if the answer is that actually it’s not unusual to have multiple tracks solo’d and muted … how are you using Render In Place?


Thanks -

Muting won’t affect RIP.
Solo I don’t know, I have never dreamed of trying that, but that is really only one mouse click to disable all Solo before doing a RIP.

It’s what comes after that though … I don’t know a reliable, quick way to reproduce the original mute/solo status of the project afterwards.

Maybe the new mixer history function can help? Or is there another hole in my knowledge (again)?

Thanks -

you must select the single event

Yes, thank you tektronik, I have been selecting the single event.

Bug report created: https://www.steinberg.net/forums/viewtopic.php?f=253&t=120907 . Thanks for everyone’s help.