Render-In-Place ignoring MIDI expressions

Hi there. I’m running Cubase Artist 8.0.4 with a Novation Impulse controller running Arturia’s Analog Lab 2.

I’ve recently been tracking, using the read/write automation switched on so that any MIDI expression controls are recorded and played back, as I have done many times in the past. I then render the MIDI files into audio using render-in-place, but now I find that the MIDI expressions (modulation wheel/sustain pedal etc) are not being rendered along with the actual notes, UNLESS i export the MIDI track as an audio mixdown in real-time. If I try any other method (render-in-place in fast or real-time/audio mixdown in fast mode) the notes are rendered without expression.

Obviously I’d prefer not to have to render in real-time for every track!

Is this a bug with Cubase? Or is it the Arturia software? I have had no issues with Arturia plug-ins before.

Thanks for any advice.

I could be wrong, but I suspect it might have to do with the plugin. Sometimes plugins aren’t fully VST compliant, and are intended to work pretty much only with ‘MIDI’ events.

There may also be something about Cubase itself when instant rendering (perhaps an option when you choose instant render) that makes it ignore the VST automation controller lanes when instant rendering. Keep an eye out for such check boxes when you try to instant render.

If you don’t notice any such settings and flags when invoking instant rendering (or in the Cubase main preferences dialogue), don’t give up just yet…you can merge the VST automation lanes into true MIDI data on a fresh track and try it that way.

What happens if you take such a track and ‘merge’ it to a new track?

What I mean by this is merging all that data on the track’s automation lanes into the MIDI part itself…

To try this…

In the main project view window…

  1. Duplicate the track you want to instant render.
  2. Set the left and right locators so that all parts on the track are included in its range.
  3. Click solo on the track you want to instant render (or mute all other tracks but the one you want to merge).
  4. Click your duplicate copy of the track so that it becomes the active track.
  5. Choose from the MIDI menu ‘merge…’

You’ll get a pop up that asks for some details on how you want this merged. Set those as you like, take care to choose any options that convert VST expression into MIDI, and choose to replace the destination track.

Cubase is then going to take all the MIDI parts on any unmuted DAW tracks between the left and right locators, as well as their controller lane events and merge it all to a single MIDI part on the target track. All of the CC stuff that you had stored in DAW controller lanes gets set up inside the MIDI part itself…

Once this is completed you should find that all the parts on your duplicated version of the track have been replaced with your merged MIDI part. Now all of the CC data that was on track’s automation lanes are instead MIDI events in the actual MIDI part.

Now solo your new merged track and see if that instant renders properly.

If it does, then consider keeping CC data in the MIDI parts in the future instead of on DAW controller lanes when using that particular plugin. Using the in-track MIDI key editor with some controller lanes set up on it comes in handy for situations like this.

Hi there.

Thanks for your reply. I tried your suggestion and it still didn’t work. It then occurred to me that maybe (as you first suggested) it was Arturia’s new Analog Lab 2 program itself. I bought their V Collection 3 last year and so I have all of the software synths from that package, and they all work fine, no issues. However, it is this new version of Analog Lab (which I was able to upgrade to for free) that has the problem.

I shall let the bods at Arturia know and hopefully they’ll be able to address this issue in an update.

Thanks again for your time!