Render in place in Cu pro 8 better than Cu pro 9

In CU 8 render in place was working very good with halion multiple midi output and with their name but now I tried same but it dose not work if i do

1- open halion SE , halion 6 , halion sonic 3
2- assign multi instrument to multi midi track
3- name midi tracks as per assigned instrument
4- arranged instrument output from halion (output1,2,3,4 etc
5- connect them with midi tracks
6- make midi data
7- render in place for midi track

the result for each midi track i will get renderd version of midi data including empty tracks same number of the assigned output for example if i make 3 midi tracks and 3 output i will get 9 renderd version with same name of the instrument track


can any one treat this issue and explain how to do it as before


Hi,

Are you sure you used multi-outs in Cubase 8?

Yes 100%

I tried many times to insure this is an issue with cu pro 9

If u make multiple output you will not get what you expect from render method also you not get the renderd track name .

The good thing with cu pro 9 u can render all linked midi tracks to instrument track with only main output . But without their name

What RIP settings do you have, please?

I just tried with Cubase 8.5 (As Separate Events | Dry) and the result is exactly the same as it is in Cubase 9. Three new tracks are ceated And it makes sense, because Cubase doesn’t know, which Return Audio Channel is assigned to the MIDI Track. So it’s always necessary to Render all Return Audio Channels.

Hello it seems that u don’t get my idea.

In cu 8 all midi tracks will be renderd to audio track with same data and same name . Also all midi assign to different output . If i do same in cubase pro 9 the result will be as as picture that i attached up

What is wrong on the picture from your point of view, please?

Cubase 8 working as i expect
Cubase 9 dose not

The are same file just i opened them in different version and as u see they have different process.

I can see, there are differences.

Cubase 8 exports only 3 tracks, Cubase 9 exports 9 tracks. Is this what you are referring to?

Funny i discovered that when rendering the new rendered track auto connects to a group. Never noticed to be able to do that in Q8. Maybe i selected the wrong settings but i’m very pleased to find this option now.

Yes
And to figure out the point. I assigned 3 output and i connected each one to different midi track . The result was clear and correct in cubase 8 also with their midi track name

As u see in cubse 9 i will have all midi track multiply by 3 wich doesn’t make sense . it seems like a bugs or something else . I don’t know If there is an option for that .

Hi,

As I explained, the result is correct, how it is in Cubase 9. And you should get the same result in Cubase 8 too (actually I didn’t try in Cubase 8, but I tried in Cubase 8.5, and I get the same result). Why you have to get 3 tracks? Because Cubase doesn’t know which Audio Return is assigned to the MIDI track. So Cubase always Render all enabled Outputs, to make sure, one of them is the one, where the signal is.

Actually, I tested it with Cubase 8.0 right now, and the result is again the same, as I would expect, so the same you can see in Cubase 9.

Could you make a video, where we can see the settings of the project you used in Cubase 8 (MIDI routing, internal routing of the signal in the Instrument, and the Audio Returns), the Render settings, and the result, please?

This is a video as u asked


https://youtu.be/-66DmMfixCA

Hopefully i did something wrong .

Hi,

Thanks for the video. It’s pretty blurred, but I tried to guess what you did. :slight_smile:

What version of Cubase 8 exactly do you have (it’s too blurred, sorry)?

https://youtu.be/G0zO4_FAW_0

Sorry about that video check this link

Thank you for this very nice video. As I can see, you have the very 1st version of Cubase 8.0.0, but I tested it on Cubase 8.0.40, i.e. the latest update. So it seems, this was fixed during the Cubase 8 live-cycle.

To be honest, I don’t know the exact scenario, where it didn’t work with Cubase 8.0.0, but I’m pretty sure, there was (at least) one. Maybe it was with 3rd part plug-ins. I remember I was also wondering, why it is like this (this is why I know it). And I got the answer, I already wrote you. Cubase doesn’t know the internal plug-in routing. So to be on the safe side your track is really rendered, all outputs are rendered for all sources.

any how this feature is working nice and as it should be in Cubase 8 .0.0 the bad thing is what new versions are doing .just imagine if i have 16 active midi track and all will be render multiply by 16 means 256 new audio track .this is stupid thing . if u have a solution for that . the idea is very clear now please .

What is there anybody face this issue?! Anyone can help!!!

Hi steinberg. No solution for this topic issue with cubase .

Please any one can answer