Render in place makes to many tracks

Hi

I use render in place a lot for saving cpu on e.g. Omnisphere. But everytime Cubase renders all 8 tracks ( all activated outputs) from Omnisphere instead of only the one I highlighted. Is there a way to avoid this ?

Hans Henrik

Hi,

Cubase has to Render all enabled Audio Returns, because Cubase doesn’t know, where is the source MIDI signal routed to. This information is holt by the VSTi only.

Ok thank you for your answer. A future request must be to able solo one track and then render only that track.

Hans Henrik

It’s not problem of the track. It’s a “problem” of the Audio Return Channels.

You can route multiple MIDI tracks to the Instrument track (where the VSTi sits). And the the VSTi can handle multiple virtual audio outputs (Audio Return Channels). But Cubase doesn’t know the internal VSTi routing. So the only safe way is to solo the MIDI track (if you use only one MIDI track, then it’s the Instrument track, in fact), and Solo all Audio Return Channels. Then it’s 100% sure, the wanted signal is rendered.

Imagine the Instrument Track/Channel as 2 entities, in fact. The MIDI track, and the Audio Channel. For better handling, it’s glued to the one Instrument Track.

1 Like

Its midi track routed through a vst rack channel. So I know it has an audio output track too. But when you solo the midi track you solo the audio output track too. So for me it is a future request that Cubase only will render the tracks where the audio output is coming from.

Actually this is the point. When you Solo the MIDI Track, all Instrument Return Channels are soloed too.

Yeah. But if I mute all the vst output channels but one + the midi channel, Cubase still renders all eight channels. I still think it would make sense that it was possible to only get the one that is soloed.

I totally understand your point, and see the use case. It’s totally valid and it makes sense. Lets hope… :wink:

I guess this is not a feature yet?

+1

Proper render in place for MIDI tracks pointing to multitimbral rack instrument would be great.

I would like to render-in-place the associated instrument audio return channel for a MIDI track pointing to Kontakt (rack instrument) and I mean only the single instrument output channel associated with that particular MIDI track (as specified by me in the Inspector of the MIDI track). Is there any way to do this?

I often export tracks dry to send them off to a mixing engineer. The option to dry render-in-place selected MIDI events would be so much easier than manually bypassing all instrument channel processing and using Export Audio Mixdown…

1 Like

Instead of using multi-outs on synths, where possible, stick with a stereo instance. This is how I overcome this problem most of the time.

2 Likes

+1

Actually I also do not understand why this is not working. There is the option to select a specific Output of a multitimbral rack instrument in the MIDI channel itself. Why does it render all the audio channels of the rack instrument when applying Render In Place to that specific MIDI channel wich is linked to one audio channel?

try that with say, an access virus :slight_smile: - and thank you for helping me seek very enjoyable thrills :slight_smile: