Render in Place outputs empty audio

I just upgraded from Cubase 9 to 12. When I’m rendering a specific VST instrument track I get an empty audio file (no waveform). I had done exactly the same thing in Cubase 9 without any problem. What has changed or what am I missing here?

Is the track record enabled by selecting it for render in place? If so, it can render an empty file.

I checked that indeed but deselecting the record button gives the same outcome, an empty file.

Are the locators placed appropriately (including not being reversed)?

I thought selecting the event suffices? Can’t recall I ever had to set the locators before doing an RIP in Cubase 9?

You don’t have to. It should work just like it did in Cubase 9.

It might be helpful to list which VST instrument you are using and post a screenshot of your Render in Place settings. Try performing a “Dry” render. I would also double check what the VST instrument is routed to.


The VST instrument is Analog Lab V. The instrument track is routed to Stereo Out. I tested in the same project rendering another instrument track (Pianoteq 7) with the same render settings and that’s succesfull. So the problem appears to be in this particular track.

I took the easy way out and copied the event to a new instrument track with the same VST instrument. Now it works! Don’t know what the exact cause was but well…

If you are using Direct Routing and are using any destination Slot besides the first (top) one you will get a blank Audio File. It doesn’t matter where the Slots are routed, but the first one has to be active in order to properly Render the Audio.

1 Like

Thanks for the tip though I did not use Direct Routing in this particular project.