Render montages: naming schemes can't get track titles

I’m trying to render a batch of montages into audio files. The key stuff I need in my file names are and .

My montages have the cd text setup with album name and track names. In the CD tab, the track names are also in the ‘name’ column. I setup a ‘naming scheme’ and it gets the montage name as and as album title>. When I try to use track title>, which is populated correctly in the CD text data (and in the cd text column of the CD tab in the montage.

But the naming scheme behaves as if track title> is blank. This seems like a bug, but I"m open to allegations of operator error :wink:.

And, especially, I would like a workaround if there is one.


This is WL10.0.0 Pro on a mac

How are your markers named? I can say for a fact that using the marker name as the track title works in the naming scheme.

I regularly render files from the montage that are based off the marker name and the naming scheme also adds the track number:

01 Track Title
02 Track Title
03 Track Title


Track Title_1644
Track Title_2496

There is a command in the CD Tab/Functions to rename the markers as CD-Text track titles in one click if needed.

I’m not at a computer with WaveLab Pro active so I can’t say for sure if you’ve found a bug or if it’s user error, but if you need to get this done right now, try using the track marker names.

Thanks for the quick reply Justin. My markers are red CD track markers (start and end on each track) and they are already named to match the track names and CD text. I think I added the CD text after the named markers didn’t work.

I didn’t use the CD wizard to create this - I created montages and inserted markers in them, named them, added CD text, etc. I’m using the ‘naming scheme’ window to construct the rendered file names, and I don’t see a way to use track marker names via the ‘auto variables’ (but I do see how to use cd text track and album names - it’s just that the album name is working but not the track names). Are marker names accessible via ‘auto variables’ in the ‘naming scheme’ tool, or somewhere else?

This is for a set of comparative tracks, not for actual CD burning, mind you. Which probably makes no difference.

So, I might be missing something, but it still appears not to be working.


I’ll be back at a computer with WaveLab Pro tomorrow but I was able to remotely check my naming scheme.

It’s a little vague but I use the “Name” option and after doing this, WaveLab considers it to be the “Region Name” which on my system always grabs the name of the track marker.

It’s been awhile since I set this up, but when you are adding an attribute to the naming scheme, just try the “Name” option that appears in the dropdown menu to see if that gets you the track name.

Like you (I think), my marker names always match the CD-Text name 100% so these are interchangeable in my workflow.

When I try to use the “name” field in the ‘naming scheme’ tool, the name matches the CD title. Or the Montage name - not sure which because they are the same in this project. But it definitely does not match the track titles (either marker names or cd-text track names). Will experiment further tomorrow. Out of time today…


OK: in the ‘naming scheme’ dialog box, in the preview field, the ‘name’ field doesn’t put anything in the preview field. cd-text->name puts [cd track name] in the preview field. I’m not quite sure what I’m doing differently now, but I managed to render some files named - a day or so ago, but it’s not happening now.

Anyway, rendering a batch of montages with the naming scheme - does render filenames that match. I’m backing away now, as it is doing what I need :wink: