Rendering midi to audio results in audio behind the beat

Stumbled on a problem which has stopped my production in its tracks.
i mainly work with midi drums along with bass,guitar’s and vocals.Not had the chance to Finnish much recently due to being busy so not rendered my drums they are still in midi and i have tracked audio to them.recently i have been messing about with scoring style music just for fun and had some good music coming from it.
I decided to make a full hour piece of music and was using padshop for some texture.i decided to mixdown the track to audio and then added some hats style percussion to emulate a ticking clock.the already rendered track had a hit in the middle of it which in midi was perfectly in time but slightly out only by a few samples when i rendered it.when i rendered the hats which were perfectly quantised in midi they were slightly late too this then led me to start testing with other vsti’s eg superior drummer ect.every time i render a 1/4 kick drum perfectly quantized they end up behind the beat in audio.This really bothering me because i have spent time tracking well played and timed parts to midi drums that i plan to render to audio to use plugins on.even if i was to just mixdown the song without bouncing the drums first when i do mixdown the drums are going to be slightly out which will spoil my hard work in midi humanising my drums and will effect the over all timing of my tracks.

I have contacted steinberg support about this they have advised i trash my preference folder but this has made no difference.i will be getting back to them tomorrow so hopefully they will be able to help me work this out but in the meantime I was wondering have any of you experienced something similar or could you please try this on your system and see if you experience the same.


Thanks in advance

Few spec’s
Asus based i7 2600k over clocked to 4.5 16 gig ram windows 7 pro 64bit cubase 7.5 rme fireface 800

If your exporting in real time then it’s a latency issue if not in real time then time to check if it’s your sound card drivers??

Hey Limit cheers for the input.

This is happening either real time or just mixdown its even doing it if i use the bounce feature in superior drummer? This lead me to try using grove agent its exactly the same still?

A friend rang me today who also record’s hes mainly using pro tools infact hes just moved to version 11 and been 32bit up till now.when i told him of the problem i been having he told me about his move to 11 64bit and having the same experience of midi being rendered out of time.his problem was not having delay compensation activated in pro tools once he set up the delay comp all was good.

I already tried activating delay compensation button in the top left corner in cubase but it made no difference.
am i missing something under the hood here? Are there any more setting’s for it.

Heard back from support but they are pointing me to the elastique audio settings but musical mode is not activated on any of my files in the pool.
They also suggested i install 7.5.40 and the latest version of elicenser which i already have installed.

Im stumped :question:

Try doing exporting the same kind of thing in a new fresh project with just the stuff that’s going out of time. Don’t import the tracks from your project. Create new ones to test. It could be a vst causing problems. See if the delay still happens on a fresh project. We will go from there. What sound card are u using?

Im using a fireface 800 bud.
gona start a fresh project now and have a go.

Done a bit of testing its tighter when i use superior drummer in a project 44.1 than 48.
Problem i had is my projects are in 48 so i could export the midi file put it into a 44.1 session render it and import it that way back into my project.because i dont have my drumms quantized to give it a human feel when its rendered in the 48 project its really out.
Grove agent is more hit and miss depending on what kit you use some are dead on some are late.doesn’t make any difference what sample rate i use.most steinberg synths are late too but its hard to hear more visualy in the audio file.

Are you using the latest drivers for the FireFace ?

Hi Peakae
yes i have the latest drivers installed.

Not sure if I fully understand your issue, is anything fed into Cubase (real instruments, vocals etc) late, or do VST’s play fine when midi, but after render in place they are off?

Reading from the rendering make sure the tickboxes in the audiopool behind the samples are off. When on you get unwanted microtiming issues

Hi Raphie

Vsti’s play fine in midi.after i render or mixdown its off.

Did you check the wavs in the pool? Is the box ticked?

yep checked them they aren’t ticked.

This is weird after a bit of searching around it seems im not alone with this there was a person who was suffering a very similar problem over on the reaper forum.

Also someone posted a video on youtube showing the exact same problem i have.
I’ll go find it and post it in the thred.
Like i mentioned above superior drummer seams to be ok at 44.1 any other higher sample rate and it goes behind the beat.48 88 and so on but as the sample rate is increased it anly moves the once.i.e 48 and 88 are rendering in the same place behind the beat.44 1 perfect

https://youtu.be/RHfYsgMlwRA

Has to be setting or setup related this :question: