Report on large score (Dorico 1.0.30)

Dear Dorico’s team,

I have been working those last days on a quite large orchestral score (Ravel’s L’Enfant et les sortilèges, 1354 bars, arrangement for 14 musicians).
I find that Dorico can be quite slow — it took me 10s for a tie to be input or a lyric change.
I find that this slowness is not really consistent, sometimes it is not really that problematic. I suppose this is a field that is being improved. I wonder if those speed problems are caused by the fact that I was working from an original XML file.

•Some Tempi are not accepted in the tempo popover (Moderato subito e accel.)
•Still not easy to write string harmonics
•“Ordinare” playing technique missing [Edit : found it, called “ord.” — sorry for that], sul {G,D,A,E} lines with the same style as octava lines
•Unable to make 4/4 and 12/8 coexist (as q.=q) — I am not sure this feature does not exist, but I have not found it yet [Edit : just to be sure I am clear about that : there are bars where the singers sing in 12/8 while the orchestra plays in 4/4. If someone could tell me how to input that (I used 12:8 n-lets, which is not very elegant !), it would really help !]

What is really remarkable is the great stability of the program. Even though it is sometimes very slow, I have never had to force quit the app nor did I loose anything. And everything looks exactly as it should !

Daniel, let me know if you could use such a large file for testing purposes, I would be glad to send it to your team if needed :wink:

Piggybacking on #4, is it even possible to define a mm setting for a dotted quarter (crotchet) in the Tempo properties panel?

For what it’s worth, on larger Sibelius files (full orchestra, approx. 500 bars), editing can be very slow for me, especially with Sib 7 sounds installed. If I switch to General Midi sounds, the editing becomes much faster.

I haven’t tried that with Dorico - would it make a difference?


That setting doesn’t work yet, but you can create metronome marks for dotted notes by writing i.e. q.=80 in the Shift-M popover.

I also just finished entering a large score (first movement of Prokofiev piano concerto no. 3). There are 276 bars with 24 staves of music. The file size is 1.8MB. Toward the end it had gotten slower but was very inconsistent about it. I first noticed when adding a gliss to a note with a 15-note grace-note run (see image). After that was placed the performance really slowed down noticably. But on re-launching the program it was better again. But once in a while it will slow down again. Seems to be in some weird mode that I can’t put my finger on.

Also, the gliss was not visible in galley view. I ended up entering it multiple times as a result. When I went to page view it showed 4 instances of the gliss. Apparently the gliss needs to be attached to a normal note in order to be consistently visible in galley view. I wasn’t able to reproduce this with a test file using just those notes. So I am not really certain that what I described is repeatable in a smaller score.

The overall experience was actually quite good. Only one note entry gotcha. As I was adding an octave above a passage, I somehow accidentally did a select all just prior to applying the octave and notes were applied to the entire score. Luckily I caught it and was able to undo without any loss of time.

I got such a behaviour after inputting the text “unis.” attached to a note (using [SHIFT+x] ). Then I realised the text was moving around in galley view, farther and farther away from its original place. The strange thing is it occured only with that text instance. The other “unis.” were staying at the right place.

It’s entirely possible those gliss lines were off screen somewhere in galley view.

I found it very easy to add gliss notes (without text), just selecting the first notehead and pressing the gliss icon on the right panel. It has been perfectly input each time, no tweaking required and no problem in galley view…
Still no one to tell me how to write 12/8 for the singers and 4/4 for the rest of the orchestra (with the barlines at the same place) ?

You can’t write 12/8 and 4/4 and have the barlines line up at present, unfortunately, as you cannot define the required metric modulation of quarter = dotted quarter, but we do plan to implement this in future.

I would definitely be interested to see your large file, Marc. You could perhaps email it to me by way of

A hoping-to-be-former Finale user, I bought and setup Dorico. Having serious problems with speed, Dorico’s response is really slow. I’m working on a large score that has 35 staves, 44 pgs, full band, 330 measures. It was imported from an XML file out of Finale. Problems: one example, in Setup I was creating a custom score, I unchecked the box for 5 of the staves. For each stave it took 8 seconds to uncheck. There are numerous other examples.

My i7 processor runs around 3.8 GHz, I have 16GB RAM.

Any suggestions for how to increase the speed? I think I’m going to love Dorico, but not at this speed for my big scores…thanks for your help!

I have noticed that some speed problems come from miswritten bars due to the XML import (bad tuplets, notes missing to “fill” the bar…) When those problems were taken care of, some speed problems disappeared. But it is true that changing, adding or deleting instruments in setup mode is long. Well, there is a lot of calculations to be made in any change in that mode, so that makes sense to me.

On Windows, Finale is eXtremely responsive and almost totally unaffected by score size. Not on Mac though. My only suggestion would be to sit back and wait for Dorico to mature. It’s a different beast, with zillions of calculations to be made, but given the collective expertise of the Dorico team, I personally feel reassured that the speed issues will be sorted in due course.

Rebecca, some of the operations in Setup mode are certainly much slower than they should be. Some of these (e.g. adding, deleting or reordering flows) will be much, much faster in the forthcoming update. Adding or removing players from flows, however, will still be slower than we would like at least in the next update, but we have plans for how to speed these operations up; we take a “safety first” approach to make sure that these operations work reliably before we try to speed them up.

Another thing we know is slower than it should be is editing master pages in Engrave mode once you’ve got more than a few pages in your project. We do have a plan to speed this up, too, but again, it’s risky and difficult enough that we need to take the time to get it right, and we have to balance this kind of optimisation work against the need for more features and fixing other kinds of bugs.

If there are other input or editing operations that you find are particularly slow in your score, we are always interested in taking a closer look at individual projects, as we have often found specific performance problems in individual scores. If you would like to send me your project, you can email it to d dot spreadbury at steinberg dot de. We of course promise to keep the score safe, not to share it with any third party, and to use it only for the purposes of debugging and improving Dorico.

Large Score Speed solution

Daniel, thank you so much for your reply!

I have found a solution that should help many others with speed for large scores.

Mine is 30 staves and 330 measures, so I created a Flow2 and a Flow3, then I copied and pasted so that now my large score is divided into three flows. That has made the speed issue minimal, and I am able to now function to finish the score. When it is done, I’ll just paste Flow2 and Flow3 back onto Flow1 and it’s done.

In addition to Setup, the speed problems were anything that required the whole score to reorganize itself, like insert measure. With it now divided into 3 flows, I’m guessing, it doesn’t have to reprocess as much info, just the flow I’m working on.

Hope that saves others many hours of time and frustration.

Dorico is going to be great. Thanks for all your hard work to bring this to us!

Rebecca, I’m really glad you’ve got a solution that works for you. We’d still be grateful if you could share your project with us, as each one of the large projects we’ve looked at from our customers has tended to reveal another interesting aspect of Dorico’s performance characteristics that has allowed us to make improvements.

I’m going to send you an e-mail tonight. I have something you might want to look at it in this area.


Now, on Dorico 1.2, I’m experiencing slow downs, with significant delay when entering notes – though slurs and articulations and dynamics go in quickly. I can enter a string of notes, and they buffer, but I have to wait many seconds watching them go in, with a little clock icon appearing between the appearance of each note. I can’t get too far ahead, because any mistakes I make would mean more to erase. I use a MacBook Pro, 2.7ghz, Intel Core i5, 8gb RAM, solid state hard drive, on Sierra (10.12.6).

Here is the story. I’m engraving a sextet (pierrot plus percussion). It is 340 measures, one movement. Its an old piece (1991). It needs a re-engraving. I’m up to about m. 250. This is a work I began with the first version of Dorico, and abandoned when I encountered a problem that awaits an update. Problems that have been fixed have involved adjustment of note and staff spacing, pedaling, working in multiple voices. Each new update meant I returned to the piece and picked up where I left off. The most recent update, with cues, had me return again, and I’ve been working in earnest. It has been quite good, and I’m getting pretty fast at the program.

Except – as my skills with Dorico have increased, the program has been slowing down! I searched the forum, and have tried some tricks. I don’t remember how I set up the master page (I was a Dorico beginner, and it was a long time ago). But to speed things up, I put a frame break in m. 1, and I set the systems-per-frame number to 2 (I want two systems per page). I am doing all of my entries in Galley view. Those gave the program a bit of a speed boost, but another 50 measures later, the program is again slowing down a LOT.

MOST impressive is that edits and adjustments when switching to engrave mode are surprisingly few! The casting off, the note spacing, the staff spacing, handling of most things over system and page breaks – it is all incredibly impressive. I do have to adjust slurs, especially on groups with big register jumps and over breaks, but not all that often.

I just wish I could get this speedy again!

Any ideas would be greatly appreciated.

Note to Daniel – if you want me to zip this file up and email it to you, I’d be happy to do that.

David Froom

One thing that makes a huge difference for me is closing down all tabs except the one I’m working on. You can also try making a temporary layout that only contains the instruments/flows you’re working on.

Hi Anders,
Merry Christmas to you – and thanks for writing back!

This file has only one tab, and only one flow. This is a single-movement work. I could try entering music one instrument at a time (with that instrument only showing). I’ll report back on this.

Thanks again,

Well, I tried just unclicking the show tabs button, and even though I have only one open tab, this sped things up considerably.

I tried just showing single instruments, but couldn’t get things to work because those show multi-measure rests, preventing me from adding new music.

So things are almost humming along.

Thanks again,