Requantize to quater triplets is not working as expected

I should state the the origin of the notes is from MIDI import, so perhaps there is a related issue with the import. Here’s the note sequence in Cubase:


Quantized to quarter triplets.

Here’s how it looks in Dorico: (with “played durations” option turned on for clarity)


After requantizing with those settings:


I get this:


When do I “undo” I get this:


I cannot “undo” again to get back to the original.

Here’s the expected result:


What’s going on here? Is that a bug? Is there a workaround?

EDIT: This only reproduces if you have lyrics on the notes.

You could try setting the quantisation unit to crotchet? Or (probably quicker) you could simply change the durations of the ‘wrong’ version.

I did some more investigation and turns out this bug only reproduces if I have lyrics.

I also tried changing the quantization unit to a quarter note (crotchet) but it still reproduces.