Request for user feedback- Latency when using Ozone 7

Not sure I can explain this. With Ozone 7 (or was it 5?) active on the main bus, I was getting an unuseable amount of latency from my midi controller to any VSTi loaded. For the first time ever, I (grasping at straws), clicked the icon in the upper left toolbar (something about latency compensation…sorry, gonna rtm in a minute), and the problem went away. Initially, I tried bumping my buffer size from 256 to 512, but no dice. 256 had been working fine for years. Not saying there is a problem with Cubase 8.5 Pro or Ozone 7, but rather, likely ignorance on my part.

There is something nested deep in the Ozone preferences regarding latency compensation, but I have not gotten that far yet. If any of you have some light to share, I would be grateful. In the meantime, I’ll put on my reading glasses and revisit the documentation. It just seems strange for this to occur. Things that have changed are going from 8.0.3 to 8.5 and jumping from Ozone 5 to 7. Part of my confusion was that I was toggling back and forth between O5 and O7 on the master, comparing the results. Having both of those loaded, even with only one enabled at a time might be the culprit. Hmmm.

Just wrote a long detailed reply that got eaten by this stupid forum logging me out every couple minutes. :imp:

So here’s the abridged version.

Ozone will have latency. Probably there are settings to minimise it.
The Constrain Delay Compensation button is just turning off any plug with latency.
Make sure when turning plugs off if you are comparing two that you aren’t just bypassing. Clicking the rack power button does not turn the plug off, only bypasses it. (Alt click I think will turn off)

Thank you Grim. I know the eaten post thing well. Good point about the power vs. bypass button. I tend to always just bypass. I’ll watch for it. As soon as I have a quiet moment, I’ll study a bit and get a full handle on this. I’d no more by now had it been an issue in the past.

There are two types of latency, one is caused by the sound card buffer size and the other caused by plugins.

The former represents the way audio is split into chunks to be played by the soundcard - implying that when you play a midi note into a VSTi then the sound won’t appear until at least the next chunk of audio comes out, hence a delay and latency. You can change this via the soundcard settings.

The plugin latency is the amount of audio that the plugin needs to ‘hear’ before it will send out resulting audio. You can’t change this. It is set by the plugin and it is like using a delay line. Most plugins have zero latency, but some complex plugins, e.g. compressors, will need to look ahead in the audio stream to give a better effect and therefore they will introduce a sizeable delay. Behind the scenes, when playing the project Cubase automtically sends the audio earlier to these plugins so it is all in time at the output, but when playing live through these plugins you will have the delay. There is nothing you can do except turn off the plugins. As said earlier, the Delay Compensation button simply turns off those plugins which introduce delay/latency, so its quick to use.

I would guess Ozone has a high plugin latency. Sounds like it also has some preferences to lower that latency. You can see the latency of any plugin in the PluginManager window by selecting the plugin and looking at the panel at the bottom which gives plugin details (click the ‘i’ icon at the bottom/left).

For example, I have my sound card set to 1.973ms output latency, which is great for live MIDI recording. But if I add a UAD Precision Multiband Compressor on the output bus of my mix then it adds 16448 samples of latency which equates to 373ms at 44.1kHz - that’s over 1/3 second!!!


Ya know what Mike? That is exactly what was happening. I had noticed some quirky behavior where certain plugins were not responding to power/bypass clicks (in this case Ozone). I thought it was a separate issue for another thread. It had to be because I had the Constrain LC button on, but wasn’t sure how it was doing it’s magic. Likewise, I don’t normally track into Ozone (conventional wisdom), so likely, this is why I’ve only just encountered this behavior. There is definitely potential for a substantial amount of latency in Ozone, depending on modules used and how they are configured.
Thanks for that info, seriously. I see the picture now.