Resetting a Layer midi continuous controller does not work

Resetting a midi continuous controller back to nc is not remembered.

  1. open the midi continuous controller panel for a layer
  2. select any controller and click to choose a cc number to assign. e.g CC#10 Pan. Pan is displayed
  3. click again and select nc to clear the selection. Its label is reset to nc
  4. hide the panel.
  5. Open the panel again. The controller clicked in 2 has reverted to showing Pan. The has been forgotten.

Whilst I’m here, how about putting a button to open the Layer Controller Mappings dialog alongside the layer midi controls? I wanted to disable the modulation on one of my layers the other day and it took me a while to find (remember about) the controller mappings dialog. Great feature by the way, once I know where it is… It seems strange that it is hidden away in a menu and not discoverable unless I go read the manual!

That I can only do in the 2nd column, ok. I set cc#2 (Breath) to cc#10 (Pan).

There is no nc here. I can set it to “No Mapping”, which resets the mapping so that now the 2nd column shows cc#2 (Breath) again (means: no mapping).

I’m under the impression that we talk about different things. After resetting to “No mapping”, closing and opening the Layer Controller Map again, cc#2 shows cc#2, that is, no mapping.
I guess you mean something else?

Sounds like a good idea, we’ll check.

Like so?
Next version.


Yep, new button looks good to me. Will speed up getting to the mappings and I’m sure others will find it helpful too.

I’ll look at this properly later and put a screenshot on. Your description doesn’t match what I think I’m seeing but I don’t have VST Live in front of me right now.

Apologies for delay in replying. Small matter of holidays to have been on. Anyway, here is the issue, with screenshots.

  1. Open a layer and click the button to show the midi continuous controller panel

  2. Click on the first control to open the menu panel , and select CC#2 Breath. Note that there is a nc option at the top of this dialog.

  3. CC#2 Breath is selected

  4. Click on the control again to open the panel and select NC. Breath has been cleared and NC is now shown

  5. Change to a different part or song. Then return to this part and this layer. CC#2 Breath has magically returned.

  6. The same behaviour occurs if I save the project, move to a different part/song and then return to the layer. CC#2 Breath will return. The only way I’ve found to get rid of the CC selection is if I save the project then reload the project immediately. This will clear the Breath selection and return the control to nc.

will check, thanks!