RESOLVED: Problem with imported XML file: Can't enter measure rests in empty bars

I’m working with a file which I exported from Sibelius in Music XML and imported into Dorico.

There’s a section of the piece where some measures in some staves were empty upon import. No notes, no rests - nothing.

Having no idea what caused this, I tried a bunch of things, to no avail. Then, while writing a draft of this post, I stumbled on the solution for all but one of the problem staves:

The last note before the empty bars had “Ends voice” toggled ON in Properties > Notes and Rests. When I disabled it, the measures immediately populated with measure rests. Great! This is what I want.

The one remaining problem staff does not have any preceding notes with “Ends voice” enabled (nor “Starts voice”, for that matter).

If I enter a note in any empty measure in that staff, the subsequent measures immediately fill up with measure rests. If I delete the note, the measure rests disappear.

If I fill the entire section with whole notes, I can delete all of them after the first measure of the section and they’ll be replaced by measure rests, which is what I want. However, if I then delete the one in the first measure of the section, all the measure rests disappear.

EDIT: See the post below for the solution.

Found the problem. Rather than delete this thread, I’m presenting the solution in case it can save anyone else the time I spent sleuthing and/or provide the Dorico team with helpful information.

Immediately preceding the measures in question, some instruments had a 4-measure repeat symbol. This was brought over in the XML file from Sibelius, not entered in Dorico.

Out of curiosity, I deleted it. When I did that, something odd happened:

1.The four bars became three

  1. The middle bar had 8 beats (quarter notes)

  2. A signpost appeared at the start of that long bar: “4/4 (q, 1+1+1+1)”, and “Hide Time Signature” was enabled in the Properties window.

When I deleted the signpost, the three bars correctly switched back to four.

Next, I selected the measure rest in the 4th bar of the problem staff, and, lo and behold, “Ends voice” was enabled. When I disabled it, the empty measures filled with measure rests.

Problem solved!

1 Like