Restore Purchases in Cubasis 2 - not working

I have a new iPad pro and would like to use my purchased FX again. I click in the fx section on the restore purchase button and i then get a message that purchases were restored - but nothing. I cannot use the FX that i bought. :blush:

Hi pummelfee,

Thank you for your message.

Normally there should be no problems to restore previous purchases.

Which IAP did you bought and did not restore with Cubasis?
Are you able to shut down and restart the iPad to give it a retry?

Please keep me updated.

Best wishes,

Do i was working with my desktop system for a while, i now tried to re-install, re-boot… I got the FX Pack 1 long time ago and it was always working. Since the day i got a new iPad and restored it from my iCloud backup.
The Waves Plug-Ins and Classic Machines were restored, but not the FX 1 pack.
This is quiet annoying since Cubasis does not even have stereo delay onboard…

Hi pummelfee,

Normally, it should work fine to restore purchases via tapping the similar named button in the shop, when being logged in with the account used for the purchase. Please let me know if the problem persists.


Hi Lars,

sorry for my late reply. I think i discovered what could have confused me; i remember that i was supplied with an inofficial beta version to check the new MIDI thru feature. In this version the inApp Fx were unlocked. Something like this??
I‘ve tried so much apps in the last years… :wink:


Hi pummelfee,

Thanks for your additional message.
So, the problem could be solved via installing the regular App Store build?


A time ago, I purchased the upgrade to full edition of cubasis 2 on my ipad and some FX bundles. My ipad doesn’t support cubasis anymore as it is to old. On my iphone I cannot install cubasis 2.x
I installed and activated cubasis 3 on my iphone 8 but am not able to restore my in app purchases.

Please help.


kind regards,