RestoreRig does not render in WL Elements 9.5

I have an audio file and I’m using RestoreRig in WaveLab Elements 9.5 to remove noise. It works great on playback but when I render the audio, the noise is not removed. I confirmed I have not checked bypass master section when I m rendering. And I even tested my process with other plugins. They render properly. However RestoreRig does not seem to render at all. See video linked here. What am I doing wrong? https://youtu.be/EKzoHC0NmqQ

fwiw, the Denoiser renders fine in Pro here. I don’t have Elements so can’t answer for that.

Yeah, DeNoiser in RestoreRig is working here in both Pro and Elements 9.5. Looking at the video I think it has something to do with the “Learn” button being left in “ON” when the GUI is closed and rendering starts.I’ll admit that the little bit I played with RestoreRig, it’s not as clear as other noise reduction plugins as to when it’s in learn mode or process mode and I think that’s where the confusion is here.

I think you’re right Justin. I’ve had a hard time with different denoise plugins in the past between render and what I’ve heard during playback depending on where I start playback, etc. and what denoise methods I’m using.

If you turn off Learn and set it for an extreme Dynamic setting like 100%, I think you’ll probably find it’s processing during the render.

Then read the section in the manual and go back to the Static Learn method.

https://steinberg.help/wavelab_elements_plug_in_reference/v9.5/en/_shared/topics/plug_ref/restore_rig/restore_rig_denoiser_r.html

The Noise options allow you to define a section in an audio file that contains a static noise that you want to remove and then remove it.

Play back the audio section that contains the noise that you want to remove and click Learn.

RestoreRig records the audio for a few seconds.

To remove the recorded static noise in the audio file, click Reset.

fwiw, I can’t get it to render correctly with the Static Learn either, following those instructions. With standard render or render in place. I can audition it if I turn up the static level percentage, but can’t get a render with the noise removed. Maybe somebody at Steinberg could check it out.

edit: I got it fixed once with render in place where the noise was tape hiss, but I don’t know why it worked. Haven’t gotten it fixed with standard render at all with the same noise and settings.

Yeah, I would say all in all, the learning process is a little goofy compared to what I’m used to. These days I use RX exclusively but even what I was using before that, it was very clear how to operate.

RestoreRig seems to be strange in how it should operate. Maybe the manual needs some more detailed explanation and maybe somebody at Steinberg could check it out as Bob said.

It seems that either something isn’t right, or the workflow is such that it’s hard to use it as intended.

Thanks Justin. I tried Learn with the Izotope denoise plugin (in 9.5), and Freeze with Sonnox (in 9.1), doing basically the same thing and those rendered ok. I noticed you could save both of those as presets, apparently with the noise profile, and reopen them. i tried to do that saving temporary with RestoreRig, and restoring temporary, but got the message in the picture when restoring Temporary#1. Is that possibly the issue, if another instance is created for render?

But shouldn’t you be able to save the learn noise profile settings as a preset if the others do? I thought you could do that with the legacy Steinberg denoiser, but maybe I’m wrong about that one.

Sorry to sidetrack your thread CovetedGreen.

PG, this isn’t working. Static Learn renders don’t remove the noise. You can audition the Learn noise reduction but not render it.

I thought it was just me not understanding the strange instructions in the manual, but I don’t think that’s it. I think the instructions are either wrong or incomplete:
“To remove the recorded static noise in the audio file, click Reset.” (??) That doesn’t work, no matter how I interpret it. Learn Reset just turns off the noise reduction.

With the Denoise module ON, and Dynamic at 0% and Static Learn totally off, the level of the file is reduced 1.4dB in the render. That can’t be right. Izotope doesn’t lower the file level with everything at 0%. The other modules seem ok about level.

If you tested this and found the render different from the original, indicating something was happening, I think that’s why. It’s just lower level, and it shouldn’t be. And the Learned noise is not removed or reduced.

Also, shouldn’t you be able to save the Learn noise profile in a Preset, like the other programs? The warning message says you can’t.

Can these things be fixed?

Good observations Bob.

I would say that you’re on to something. Either the manual is wrong, there is a bug/oversight with the Static Learn, or it’s just not intuitive like other similar noise reduction plugins are.

I would think saving a noise profile preset would be essential as well. I happen to do pretty much all noise reduction/restoration in RX so I guess I didn’t really look too closely into the details of how the DeNoiser in RestoreRig works.

The actual noise reduction seems to sound good but the workflow operation doesn’t quite make sense or may even have a bug. Hard to say. Either way, not good and probably should be evaluated closer.

This is issue is currently evaluated. I suggest you don’t use the FingerPrint issue for the time being.

The gain change is just as bad, if not worse. It happens if you use fingerprint or not.

I’ve had this when I using operating system on board sound driver and a connected USB external sound card ?
I can see that you are using a mac so not sure how the sound drivers are configured. I’m use bill, I like vaccines, gates windows. Just a thought. I’m sure that you’ve probably thought of that already.

Joel

Hi there,

I am experiencing the same problem in Wavelab 10 Pro.

The noise reduction works on auditioning the effect-- however, when rendered (whether single, batch process or render in place), the noise on the newly created file is unchanged.

It is not a matter of inadvertently bypassing the effect-- it simply won’t render. And, it seems that other effects will be rendered as normal. It is frustrating because I’m supposed to be working on a restoration project right now, and I’m likely going to have to go back to Wavelab 7 or something, which is not satisfactory.

If anyone has a workaround, let me know. Otherwise, yes, Steinberg should definitely look into this. It’s no joke!

I’m using a new Intel i9, plenty of RAM etc, Windows 10, Wavelab 10 Pro and an SSL Madi Extreme 64 and an SSL Alpha-Link Madi AX interface, which have all been working fine so far, except for the Restore Rig!