rests refusing to hide in voices

Hi,
In the attached example I can’t make the first rest of the middle (purple) voice disappear.
I’ve selected the following A of the same voice and tried to check the “begins voice” option but it just un-checks immediately…
(this is on the latest update 1.0.20)
un-hidable rest.dorico.zip (200 KB)
Screenshot 2016-12-21 00.22.24.png

Is it an explicit rest (i.e. a rest created using force duration-input rest) ? In this case, deleting it (it won’t display any change but get rid of the “explicit” property) could solve the problem…

Yes, Marc is absolutely right. Select the purple dotted half rest, delete it, and then set the ‘Starts voice’ property on the up-stem dotted half note.

ok this is a strange situation.
deleting the rest worked in the above file, but this file itself is just a one bar extract of a longer file (a test bach transcription to get used to Dorico).
The same trick within the longer file does not work. The bar in question is number 5. (attached)
bach test.dorico.zip (174 KB)

It’s something to do with the previous note in that voice, in bar 2 (the single up-stem eighth note on the final eighth of the bar). If you use a new third up-stem voice for the half note in bar 5, then you can use the ‘Starts voice’ property as expected. I will ask James, our resident expert on rests and voices, to look into this when he’s back from his holidays in the New Year.

Thanks Daniel.
I’m gradually coming to grips with Dorico’s multiple voice handling…
It’s a far superior system to Finale and Sibelius’s in regards to what it can achieve but the “how to achieve” part is still not always intuitive and apparent.
I’m mainly thinking about knowing which note or rest belongs to which voice without having to select voice colours or having to exit input-mode to select notes only to reselect input-mode to see which voice you are in.
Something similar to the “bracket warnings” of some code writing apps could be useful IMO, such that for instance when you press some mod-key combo all notes of the currently selected voice would temporarily flash…
But I’m sure you guys have a better solution up your sleeve :slight_smile:

As promised, James has now had a chance to look at this.

There are two reasons you can’t set ‘starts voice’ on the purple note in bar 5:

  1. The preceding dotted minim rest is an explicit rest; the first step is to delete this rest.
  2. Even with this explicit rest deleted, the voice is still active before the start of bar 5. The ‘start voice’ property only works for voices that are inactive before the barline.

To get it to work, you need to delete the explicit rest and set ‘ends voice’ on the purple note in bar 2 (which is not so simple either, as it’s a unison).

There are still some more steps we plan to take to make all of this a little easier to understand. The first is to provide some means of discerning the difference between real rests (i.e. those we call explicit, and which cannot be removed by way of the start/end voice properties) and implicit ones (i.e. those that Dorico simply uses to fill in gaps between notes, which can generally be hidden using the properties). The second is to provide a command that will allow you to make a selection (e.g. just a single rest or indeed a whole passage of music in one or more voices) and tell Dorico to remove all of the rests that can be removed in the selection, i.e. by deleting any explicit rests and setting the start/end voice properties for you automatically. I hope that both of these improvements will make their way into the next update.

Good evening,

I´m posting in this thread, cause I´ve checked every solution offered her, but I can’t solve my problem.

I´ve used the voice in green (v4 in the upper system), but deleted the notes. None of this rest has the “forced duration/position”-property. There is no other active voice 4. I can select every single rest, but I can´t delete it.

How can I get id of voice 4 completely?

(see attachement)

Thanks,
Markus
Can´t delete v4 (green).png

Is this voice being used in the piece before the screen-grabbed section? What solved it in my case was selecting the last used note of this voice and selecting “end voice”, even though this was many bars before the obstinate rests…

Thank you for your reply.
No, it´s not used before. There is no other active v4 before. There were other voices with other voice numbers, and I made sure, that every last note has the “end voice”-property. Just to be on the safe side:)

I like Dorico very much, but in these moments I miss Cubase´s score editor. You can hide everything you like and swap already written notes to voices;)

I know, they are working on it. This is only a little 3-page-piano piece. Imagine searching for “already-used-but-not-ended-properly” voices in an opera score :smiley:

yep, definitely an issue that needs some attention!

If you attach the project itself here, Markus, we’ll no doubt be able to sort it out quickly. My guess would be that you need to select each of those rests and hit Delete: this won’t make any visible difference but it should allow the ‘Ends voice’ property to work as you expect.

Hi Daniel,

thank you.
Perhaps I overlooked something.
Musical Diary for Piano.dorico.zip (252 KB)

The problem is the duplicate tuplets in the “green” voice, which are filled only with rests. Delete those tuplet brackets (by selecting the ‘3’ digit) and the rests should all disappear.

Daniel, thanks a lot. It solved the problem.
So I guess, I should always look for tuplet brackets filled with rests in similar cases… :wink: