Retrologue 2 crashes Logic Pro X

I just updated my Logic Pro X to it’s latest version and now I can’t open any projects using Retlogue 2 plug-in :angry:. If I create a new, clean project and try to use Retlogue 2, the result is the same. I’m still running El Capitan since there are no Sierra drivers for my EIE Pro.

Any ideas how to fix this?

Same here. Have you found a solution?

I’ve had similar problems since updating to a certain version of Logic Pro, must’ve been the same as it was about a year or so ago.

I can open projects that contain Retrologue 2 instances fine, but if I then load another project that contains any Retrologue 2 instances Logic will crash instantly. It will also crash if I change any audio preferences, it must be something to do with reloading the audio device. So to switch between projects I have to quit Logic and reload.

Retrologue can also crash Logic just when you’re tweaking about with the parameters, was just experimenting with sweeping the cutoff and it crashed.

I’ve contacted Steinberg about this numerous times and they’ve offered zero support and don’t seem to care. The problem’s been going on for a year and a half now and they’re well aware of it but are doing nothing about it.

If anyone can help that’d be great!

I can say that for me sometimes logic will not crush, but most of the time it will. Also its not only retrologue2 but every Steinberg vst. Logic crush if I try to open pad shop pro… halion sonic… I have both logic and Cubase on my mac. I spent a lot of money on Cubase and the vsts. I am thinking to stop using Cubase and start using only logic because Steinberg zero support. I like their products, but when it comes to support they are acting like an outdated corporation.

Here is an old (2015) fix for similar problem.
Don’t know if I should try install this, because its from 2015.
Hello again,

Today we have released the new Audio Unit patch.

The patch fixes issues that you may encounter when running our VST instruments on Mac OS X versions 10.10.5 (and earlier) in AU hosts. Please make sure that the latest version of the plug-ins is installed before installing the patch.

Please visit the support download page for your VSTi product to download the patch, or follow the link bellow: … er_mac.dmg

Best regards,

Thanks for this. But the second link you posted doesn’t work? … Seems like it’s incomplete.

Yeah sorry for that :blush:

Thanks. Didn’t work unfortunately, still the same problem.

I opend logic and checked again. For some reason the problem has been fixed. I did not installed the update from 2015. The only thing I can think I did lately is to install some minor update for osx and reinstall the elicenser application to the latest version. something clearly happened because now when I open dark planet and go to the presets browser it opens inside halion sonic. When I tried to do this a month ago, the presets browser looked different and very buggy. It was impossible to choose a preset. now its fine.

update: checked again… opened retro and logic crushed :frowning:
but… I’m sure something is different because the browser window.

It seems ok now after the update to mojave. I worked in logic and used both retrologue 2 and padshop pro without crush. Anyone here can confirm the same?

yeah seems sorted now. Steinberg support got back in the end and sent me a new installer for Retrologue - everything’s been fine since that update.